Certain Applications Do Not Work After Upgrade

After upgrading from Zorin OS 16.3 to Zorin OS 17 Pro, certain applications do not work. I have Microsoft Office 365 installed via CodeWeaver's CrossOver. It will just sit on the little loading window indefinitely, and the main window will never actually open. Also, Waydroid does something similar. I've checked the system monitor and there are processes listed for these applications. I checked to see if there were any updates or if anything was broken or missing dependencies and no updates or issues were found. For Office 365 I also tried switching to XOrg form Wayland which didn't help as I was still facing the same issue. It's also worth mentioning that after the upgrade finished and I rebooted my machine the Zorin GUI wouldn't load. I had to fumble my way around in the CLI only environment that I was presented with until I found a solution that worked (I had to purge all traces of the Nvidia drivers and reboot, which I only figured out after about 2 hours of research and trying several different things) so maybe I inadvertently messed something else up or broke something that's not being detected by any of the tools or methods I've already tried. I haven't attempted to see if this issue affects any other applications yet however it's very possible that it will. Any assistance or advice is welcomed and appreciated.

Can you please check what source CodeWeaver is referencing:

ls /etc/apt/sources.list.d

cat /etc/apt/sources.list

See if it is referencing Jammy or Focal.
You can do the same for Waydroid.

I will check when I get home (I'm at work now) however CrossOver itself loads fine. It's Office 365 and Waydroid (so far) that's not fully working. As for Waydroid I did fully reinstall it after the upgrade (as it was partially removed during the upgrade process) so Waydroid should be using the correct sources.

1 Like

7 posts were split to a new topic: Tangent discussion on Wine and Crossover

To get this thread back on topic, I ran the two commands and for the first one, all the items in that list reference Focal, however for the second command, all the items in that list reference Jammy. I should mention that CrossOver doesn't appear in either list (which is not surprising). This leaves me with two questions:

  1. Is the reference to Focal from the first command going to be an issue and if so how do I fix it?

  2. Is there anything else I should try?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.