Changing default Screenshot target folder in dconf-edit not working

On my keyboard i use a screenshot key (corresponding to "print")

Using this ZorinOS 16 saves screenshots in ~/Pictures

I installed dconf-Editor and navigated to

I switched from "default" to ~/Screenshots
value = /home/$USERNAME/Screenshots/

Saving and leaving dconf-Editor didn't work.
Next Screenshot via key saves pics to my picture folder ~/Pictures as before.
Restarting PC didn't help as well.

So what settings are nescessary under ZorinOS 16 to change the default Screenshot auto-save directory?

Are you using gnome-screenshot tool for screenshots?
I am on Zorin OS Lite, which uses xfce4-screenshooter.
Either of these tools (gnome-screenshot or xfce4-screenshooter) asks upon taking the screenshot of where to save to - neither will auto save to that directory without the popup window asking. You can set what directory you wish to save to in this screen once. Even thought the pop up will always appear, it remembers the previous selected directory each time, so one time of setting it should be enough.
You only need click the "Save" button each time after that.

I have no additional screenshot tools installed appart from the default.

I can use the screenshot tool from the dock via mouse starting this window
This window is not shown when pressing "print" !

But more often i am using just the "print" key by keyboard. This command do not show any window asking for saving directory. It just quick saves a Screenshot as png file and appends date and timestamp.

In deconf-editor i set this

Saving these changes didn't have any effect on the quick-save or auto-save mode by pressing the print key of the keyboard.

1 Like

Ah, I see...
On Zorin OS lite, when I hit the Print Screen key, it opens the Dialog.

I remember now... it doesn't on Core. One of those little things about Gnome I find untenable, personally. Another is opening new windows defaults to minimized in the taskbar. Um... I wanted it OPEN...
I had to look this up. I found this:

For those who wondering why is it still not working, this bug is considered as RESOLVED WONTFIX , here's the sauce.

Reading the Bug report, it sounds just like your situation.
Hopefully the extension discussed in the thread above helps you.

1 Like

Nice, thanks.

It's working.

First installed the tool extension-manager via Store

Then started the Tweak Tool and activated the Screenshot location extension + changing the path to my dir ~/Screenshots

Next klick on "print" delivers ...png file in Screenshots.

Changing my settings in dconf-Editor from




didn't work either.

So thanks again. :grin:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.