Chrome based browsers do not open

On my computer all Chrome based browser do not display the GUI after installation and launch. Only Opera works and takes ages to open.
I have tried Chrome, Vivaldi and Chromium.
I know they are running because I see the processes on the task manager.

I'm running Zorin 16.1 up to date. I have an intel NUC, here is the data:

Processor : Intel(R) Core(TM) i3-5010U CPU @ 2.10GHz
Memory : 7572MB (2277MB used)
Machine Type : Desktop
Operating System : Zorin OS 16.1
Resolution : 1920x1080 pixels
OpenGL Renderer : Mesa Intel(R) HD Graphics 5500 (BDW GT2)
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : HDA-Intel - HDA Intel HDMI
Audio Adapter : HDA-Intel - HDA Intel PCH
-Input Devices-
Sleep Button
Power Button
Power Button
Video Bus
Logitech Wireless Receiver Mouse
Logitech K270
Nuvoton w836x7hg Infrared Remote Transceiver
HDA Intel HDMI HDMI/DP,pcm:3
HDA Intel HDMI HDMI/DP,pcm:7
HDA Intel HDMI HDMI/DP,pcm:8
HDA Intel HDMI HDMI/DP,pcm:9
HDA Intel HDMI HDMI/DP,pcm:10
HDA Intel PCH Mic
HDA Intel PCH Headphone
No printers found
-SCSI Disks-

Have you installed flatpak versions? Try and install from official website and see if that makes any difference.

1 Like

Great suggestion .... I have been running Vivaldi on Zorin for more than 10 months .... everything works fine ..... and that is the way I installed mine .... right from the official website ..... I think it is a .deb package but won't swear to it ....

Look's like someone got the same problem :smile:
Try this :-


Thank you all. I have installed the programs in 3 different ways. The ones available in Zorin Software center though it. Other with the official deb packages and finally installing the repositories and doing apt install. The result it is always the same.

I tried the multiples displays solution, but it appears as I only have one, as it should be

I don't know what else to try.

I had the same problem.
file manager
find google chrome
right-click properties
open with
default application

mine was set to "text editor"
changed it "Run Software"

Got here!

Restarting to see if it sticks.

1 Like

This is unusual. My first thought would be a corruption that occurred during install. I would recommend reinstalling Zorin OS fresh if feasible.

Hello all, in the end I managed to install chromium through the snap. That way it worked. So it seems that maybe there is a problem with libraries not identified.

Possibly, but I admit unlikely.
Otherwise, others would experience this issue, too.
And this is the first I have ever heard of this issue.

I would advise proceeding with caution instead of confidence. Something isn't quite working right on your build...

1 Like

I agree ..... there are a lot of folks on here using a Chrome based browser .... including me as Vivaldi is Chromium based .....

1 Like

The software is working, the process are running on the task manager, but there is no GUI rendered. Opera and Chromium with snaps work without problem. Firefox of course works.
When I launch the browser through the console no error message is displayed. Maybe it is a problem with my graphic card because I see no other explanation, but if that was the case why with snap it works but no through packages

I did more testing. I followed this tutorial to install chrome repositories:

I them proceed to launch Chrome through terminal. Terminal continues with the prompt blinking but no error message its displayed. On the system monitor I get these task running:

Those Crashpad doesn't sound too promising actually, but I get no error or whatsoever.

Can you see if removing the Configuration files for it gets it working?

rm -rf ~/.config/google-chrome

Warning: The rm -rf "Remove --recursive force" command is quite dangerous. If ever using it, always ensure that you specify its target. If you prefer for all elements of safety, you can perform the same with your GUI file manager.
Launch File Manager, then navigate to .config. If you do not see .config, then tap ctrl+h to reveal hidden files.
In /config, locate the google-chrome directory, right click and delete the file.

killall google-chrome

Then test launching Chrome Browser.

1 Like

I tried. I removed the folder as stated and launched google-chrome through terminal. The same proccess are on the task manager and a new folder it's created on .config

Maybe boot from recovery go to terminal root priviliges and from there first autoremove google-chrome and then trying installing or before go to desktop Zorin use only terminal or just using repair package in recovery mode when you booting or check if packages are not damaged. Something like that.

1 Like

This is normal - a new folder in .config would be created with all default settings.
And still, Chrome does not launch?

Trying force kill process or check on Stacer. Maybe trying installing older version.

Exactly. The same result all the time. Chromium from Snap launches straight away, but Opera even it it works take ages to open but in the end it does open.

I have tried many time killing the process and opening it again, even with different parameters on the console. No result any time. Checking the full name of one of the process I'm starting to firmly believe that the error is with the rendering by my GPU.

I think we can say with certainty that this error is abnormal and likely a corruption within the system itself.
Narrowing that down may take some work.
One option... Would be to completely reinstall Zorin OS. A fresh clean start can work wonders.
I do not know how you feel about that prospect; but over-all, it would probably be the most effective and easiest.

1 Like

A newby question. Because I did not create a partition for /home, if I reinstall Zorin will a lost the documents in there?