Continue freezing (often using thunderbird)

Hi all !
I bought Zorin OS 16 pro . I had to import a lot of mails from my thunderbird linux mint previous installation but the only way to import them was installing thunderbird from the snap store (Canonical) .
My laptop is a hp Pavilion i7 14-dv0018nl Notebook, Intel Core i7-1165G7, RAM 16 GB, SSD 1 TB, NVIDIA GeForce MX450 2 GB .
After the firts uses of the pc, the notebook continuosly freezed . I tried this solution : > sudo apt install --reinstall gnome-shell

sudo apt install --reinstall zorin-os-desktop
(see: Zorin OS 16 freezes - #2 by Aravisian)
The situation became better but now I have a lot of problem with thunderbird which continue to freeze (for example trying to open a pdf file ateched to an e mail ready to be sent ...but also trying to send an e mail) . Some suggestions ? Thnk you a lot

Now that the imports are done, why not try removing the snap version and install by apt. See if the freezes continue.

1 Like

Explain me pls: first step removing thunderbird using software manager. Right? Second step trying to reinstall it using sudo apt -get install thunderbird from the Shell? Would I loose the emails?

You can archive the emails locally so you can import them later. I'm unsure whether thunderbird creates local directories, automatically or manually...i use evolution and keep my mail in the cloud.

Snaps can cause issues because of packaged dependencies that may be newer/older/the same as what is installed in the system. It should be able to perform all of the same actions, possibly better because it's not double sandboxed...a "feature" of snap.

I imported the mails by copying and pasting the thunderbird dir. That was impossibile using the thunderbird version installed from flatpack. Other ways to import them?

First off, has it frozen on you? The majority of my emails i leave on the server, organized in folders so i don't have to worry about what device I'm on phone/pc.

Ops this is not a solution

THIS could be the solution:
It seems not to work with me but I will try more

At the end I solved installing thunderbird by Canonical, and copying .thunderbird dir in /snap/thunderbird/common . That's all .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.