Copying and moving files

[Continuing to split my big post up into separate ones! Apologies if anything seems disjointed as a result.]

2> Copying and moving files.

This is something I do all the time. Windows default behaviour was that if you left click and drag to another place on the same HDD it moves; to a different storage device, it copies. (Zorin doesn’t do that, I note – dragging from the Desktop to another Home folder copies rather than moves, ebven though they are on the same drive.) However, I didn’t always want to work out where the two locations were and therefore what would happen, I always specifically wanted either a copy or a move, regardless of locations. So I used to right click and drag between folders and desktops, then choose copy or move from the menu popup. Then I learnt a better way, of left click dragging and holding either Control (to copy) to Shift (to move). It made it even quicker to do.

Now, the right click drag method doesn’t work in Zorin. But the method of using Shift or Ctrl only half works, which may be a bug.

If I have a file on my desktop and hold Ctrl, then drag it to my Data drive, it copies the file. If I hold Shift and drag, it moves the file. Great! But the reverse doesn’t work. :frowning: If I have a file on my Data drive and hold Ctrl, then drag it to my Desktop, it should copy, but instead it does nothing – an animation shows it pinging back to the Data drive. If I have a file on my Data drive and hold Shift, then drag it to my Desktop, it should move the file (deleting it from the Data drive), but instead it just copies it. So it looks like these shortcuts have been partly implemented, but not consistently, and it depends on which direction I am moving or copying files in, so that in some directions it doesn’t work at all, or does the opposite from what it does in the other direction.

I really believe an OS should be consistent, so the user learns a shortcut, and it doesn’t have exceptions. Just like Ctrl X, Ctrl V, Ctrl C should always do the same, regardless of the program of the drive.

So, is this a bug in Zorin that the UI alters what things do depending on whether I was starting with my Desktop or my Data drive? Some consistency thing that has been missed? Or is there a better way to do it, some other shortcut for Linux? For now my only workaround is Ctrl X or C then V, which works, and I can live with, but I just need to retrain years of muscle memory for moving and copying files!

@337harvey mentioned this in your original One-Poster...
We both use Nemo File Manager on Zorin OS.

In this file manager, when you left click and drag a file, it moves the file as long as it is on the Same Drive or Partition.
If you have windows open for two different partitions or an external drive or USB< then left click and drag copies the file.
The reason for this is that On The Same Partition, recovering an accidental deletion is easier than doing so with a different partition or drive. So, it defaults to the safer copy for moving from one partition to another.

The reverse it true - you can copy or move either way, from either direction. It may be that if you cannot do this, you need to Set the Permissions and Ownership of the other drive.

1 Like

How do I check that? In Files>Properties>Permissions it says I am not the owner so can't change permissions. It's why I hate the way modern operating systems use permissions - I've had problems in the past with reinstalling an OS, and finding I can't do things with some of my own backed up files. :frowning:

Please open a terminal with ctrl+alt+t shortcut
Enter in

sudo -i

That will elevate you to Admin or Root. Now open the file manager with your elevated privileges:


With the new file manager window now open with higher permissions, please navigate to the directory you need to change permission or ownership of. Set it to your User account as the Owner- not to root. Once done and checked to ensure it is working, you can close out the elevated file manager window and the terminal.

1 Like

Thanks - unfortunately, although it lets me change it from root in the dropdowns, as soon as I select something it just goes back to root. Likewise if I "Change permissions for enclosed files" (the way to do it recursively?) and choose read/write, create/delete for every file and folder (since I just want to have full access with no problems - it's a single user system, I want to make permissions as invisible as possible) and select "Change" and then go back in, it hasn't saved any of it. So it looks like the Sudo version gives me options, but won't save them.

I'm wondering if this is somehow tied to the fact that I can't copy and move files easily between locations - some weird permissions thing. I guess I need some nuke way to reset permissions on every file and folder on my NTFS D: / Data drive so Linux has full ownership (without it breaking access from Windows). Mmm.

Update - when I closed Files, I saw this window behind it, full of errors, obviously related to why it won't let me take ownership (of my own drive and files!)

This may be why. NTFS does not support file ownership and permissions in Linux.

Can you please try terminal install:

sudo apt install ntfs-3g

Once done, please reboot, then repeat the above actions to change ownership of the NTFS volume and see if it works.

These warnings can be ignored. The reason these showed up is because you opened a Root Access instance of Nautilus, which was not able to access your $USER bookmarks since those bookmarks are in your $USER account, not your ROOT account.
This is fine, since you would only ever use your Root Account for admin functions and should not ever use it for daily tasks.

Thanks, just tried this!

sudo apt install ntfs-3g

Installed two packages. Rebooted.

Repeated the process above for Nautilus. But it's the same. I can change things in the owner and group drop-downs, but whatever I choose it immediately changes back to root. I can change the "permissions for enclosed files" to give full access to everyone, but when I next go in it hasn't changed anything, still the same.

This does make me think that perhaps the other issues where file movement and creation in Zorin are acting differently on the Desktop versus my NTFS shared data drive actually come down to Zorin thinking it doesn't have permission for me (the user) to make changes to the Data drive? However, I can open and save files and folders on it, so maybe that's a red herring. As you can tell, I am not very clear on these things, I just expected my (physically separate, HDD) D: to work with both operating systems (each of which is on a separate M2 SSD). I got past the first hurdles in Linux, where it seemed to keep losing the Data drive, and worked out that I had to "mount" it and tell it to do that every time in the Disks utility. After that it always appears. And I had done a full format of the drive first, not just a quick one. I always assumed Linux would automatically do stuff like that, or at least give the option when installing, since it's probably fairly common to have more than one OS and for them to have a shared data drive.

I wish there was an OS that wasn't multi-user, that had an option for single user only so that permissions and users and groups weren't relevant! I remember sometimes even if I reinstalled Windows on the same PC, with no changes to the D:. I would run into issues with it then thinking someone else had created all the files on the D: and somehow restrict me from doing things with them. :frowning:

I do appreciate you trying to help - if there is any way to tell Zorin the Data drive is fully open for my Linux user profile to access that can only be a good thing!

You formatted the Data Drive recently?
Is it possible to do this again? :expressionless: If so, formatting it to ext4 would be the way to go. Having it in NTFS creates a series of issues that would need to be worked around.

But it has to be NTFS so Win10 can also read the drive. One M2 SSD with Zorin, one with Win10 (for a few programs only), shared Data drive with everything I backup (personal documents, work files, 3D assets etc). If I only used Zorin then yes, I'd format everything as ext4. (Some of this setup stuff was in the original post that I was asked to split, sorry for the confusion!)

I formatted the data drive just before I installed Zorin and Win10 on the empty SSDs. It took a whole day to do a full format and then copy all my files onto it (over 1TB).

1 Like

Ah, I see.
Hmmm maybe others that are well versed with modern Windows can be more help. For example, @337harvey.

Windows and Linux are pretty different. There may be some give and take. Do not lose hope, but please keep in mind that those differences may, at times, be stark.

1 Like

Cheers. I'm really pleased that I have got this far - I can access and do stuff on the drive from both OSs. But some of the issues with moving files might be fully resolved if this is the underlying cause, making it even easier to do my daily work on Linux. It's going well so far!

1 Like

I was wondering why a simple copy and paste question thread was still going, so I decided to check it out. Imagine my surprise when I found out that your drive was formatted NTFS for Windows. Yep, there lies the problem right there.

I realize I can't speak for everybody, some people are forced to use Windows10 for their work, I get that. But if its for a personal machine, I'd kick Windows to the curb where it belongs. For the record, I sent my Windows7 installation disk out my Window, flew like a frisby, into the neighbors yard, and happily got run overed by their lawn mower.

I'd format that drive a lovely shade of GPT, with a delicious flavor of EXT4. Then I'd install Zorin OS 16 at my earliest convenience. But thats what I would do. You do you, and I'll be happy for you. HEHE


Your Tech Support Guru

1 Like

Unless it's ext4 you are not going to get that functionality from Linux. You could try giving the fstab entry God permissions (0777) instead of 0007. But I'm thinking that won't do it either.

Your probably stuck with keyboard shortcuts then. Sorry bout that.


I spent a year working towards switching to Linux: changing default software (e.g. Outlook to Thunderbird), doing research. It turned out I still needed Windows for two purposes.

1> Daz Studio. This is part of my business. It has loads of over-complicated interconnected parts. I looked into whether it would run in Linux via Crossover or Wine - not really. I looked into a VM - nope, turns out the GPU can't be shared between the main OS and the VM, but I would need it in both. So the only option is dual boot. And to have my files available to both OS requires NTFS.

2< I bought games from GOG, Itch and Steam for decades. I have a crazy number, many still not played (partly because I replay my old favourites such as HoMM2/3, System Shock, STALKER, C64 and Amiga emulation). I'm going to work through the list, prioritising ones that won't run on Linux, so I at least get to play them once. After that I'll just stick to the ones I can get to work in Linux.

But that means I need Windows for now, even if I only use it every few days. I've already made a huge transition in switching to Linux. I've suggested a Linux version of Daz Studio many times, but I doubt they have any interest in doing so.

I don't understand the permissions thing I'm afraid! It's an area that I have never comprehended, because it seems so alien to single-user PC setups.

Well, if it is an NTFS issue then I will just have to live with it and use workarounds. It's funny, I read loads of articles about dual booting Windows and Linux, none of them ever mentioned dealing with a shared data drive (which seems to be an element I would have thought was fairly common in dual use setups? Especially for people transitioning from Windows to Linux.)

If there is really no way that Linux/Zorin can do basic stuff on an NTFS drive, maybe my only option is something I wanted to avoid - partition the 4TB HDD so 2TB are ext4 and 2TB NTFS. Put all the Daz Studio assets on the NTFS, and everything else on the ext4. It will be more complex - if I am stuck in Windows doing a long render I won't have access to any of my files (including work files I could have got on with). Also it means that instead of backups being D: and Desktop, it will be those plus the NTFS partition.

Before I consider this, can someone confirm that Zorin would then work in the way I expected? E.g. being able to star files in Nautilus on the HDD? Being able to dram emails out of Thunderbird, and to open the saved file with a double click? Being able to change the config of the special menus, and getting a notification if I delete files from the desktop? i.e. the stuff I have raised in my other questions? I don't want to spend a day backing up and doing this and confirming file integrity for 2TB of data if it doesn't make any difference to the issues I've had! Cheers.

@Karl . Just wondered if you overlooked @Aravisian 's left field suggestion to use multi-platform cloud storage for your (maybe often used) shared Windows and Zorin workfiles, like he mentioned at bottom of this post: File explorer – starred files - #6 by Aravisian

A Mega account may be an option for you as it provides a reasonable amount of stoage in the free plan. Not just me, others on here have also endorsed it.

However, the disparity between Win and Zorin filesystems is a problem for those wishing to open and work on files in both OS.

1 Like

That can be fixed easely, gog games, steam game and so one are running great under linux. Daz Studio Probably can run too with this tutorial.

1 Like

Thanks, but I don't want to use cloud storage. Sometimes my internet hasn't been available, and there are times I can't use it at all as it is shared with someone who does online teaching, and there isn't the bandwidth for both of us at those times. Plus my data storage needs are growing, so it wouldn't be practical. Backed up drives in my PC are the only (and hopefully fastest) option for me! (And yes, my backups are kept off-site, so if my PC was ever stolen or destroyed, I wouldn't lose my data).

1 Like