Corrupted graphics jumping around the screen changing color

My Zorin OS 16.1 Core 64bit's graphics are corrupted so badly I can't figure out how to do any troubleshooting as I can't see / read the screen enough. I have a Gigabyte GV-R6570C-1GI (low-end AMD card), and unfortunately don't have another card to swap to see if it's a hardware problem. Re-seating the card didn't help. Does anyone have any idea how I can troubleshoot / resolve this? Interestingly, the login screen is "less" corrupted, so I can actually read enough to login, but desktop is unusable, as you can see:

Dialog boxes change from rectangles to polygons stretched around the screen, text is backwards and upside down, crazy!

Thanks for your time.

Can you login in tty mode? Press Ctrl+ Alt+ F2 to get to terminal login prompt. Enter your username, then you will be prompted for your login password.
Next enter:

sudo lshw -C video

Write down the results and post back here.

1 Like

You might also try booting into an earlier kernel from Grub Menu . Advanced Options for Zorin, to see if a kernel update broke the included AMD driver.

1 Like

You may Reinstall your graphic drivers from the tty screen, by pressing,
And enter your username, then password.
In this terminal try reistalling your graphic driver.

To return to GUI,
Press ctrl+alt+F7

thanks swarfendor437, here's the result:

thanks aravisian, i tried the earlier kernel listed in grub but same graphics issue exists unfortunately.

those instructions are for nvidia cards, mine is amd, is there a way to reinstall amd graphics drivers from tty?

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

ok, ran those commands successfully, but unfortunately after reboot same issue:


i assume that because bios/grub/boot screens display fine, that it's not a hardware issue.

I agree. I would not think hardware, just yet.
Did these graphics work, then stop working?
Or has it been this way since install?

been working for at least 6 months, just happened all by itself. i do install OS updates as prompted regularly. My memory is not perfect but i don't recall seeing this issue immediately after an update, although it seems an update would have been the most likely cause. what's weird is that photo i posted above is after a reboot and before login, but you can see it's somehow remembered graphics (the terminal showing a ./go command being executed) that were on the screen at a previous boot up. so graphics artefacts are persisting across reboots? very surprised by that.

Might be worth checking on amdgpu forum:

Thanks I followed that link and at the bottom it linked to where latest AMD gpu drivers are available for ubuntu. Downloaded and had to edit amdgpu-install script to add 'zorin' as a supported OS, after that it ran to 98% then failed on building kernel module:

make.log which the error refers to contains just this:

DKMS make.log for amdgpu- for kernel 5.15.0-50-generic (amd64)
Wed 12 Oct 2022 16:12:01 AEDT
make: Entering directory '/usr/src/linux-headers-5.15.0-50-generic'
/var/lib/dkms/amdgpu/ *** dma_resv->seq is missing., exit.... Stop.
make: *** [Makefile:1900: /var/lib/dkms/amdgpu/] Error 2
make: Leaving directory '/usr/src/linux-headers-5.15.0-50-generic'

I believe that this issue is caused by this:

It's a catch-22, isn't it? If it is set to Ubuntu, it fails because the os-release does not say Ubuntu. If you correct that, then it fails because it is not set to Ubuntu.

AMD openly supports Linux and not so openly doesn't bother to care. Part of the problem is that the AMDGPU makefile is using the /etc/os-release ID to set its parameters and since it was changed from the "ubuntu" ID that it was expecting to an unrecognized ID... It failed.

What you can try is to edit the makefile to include zorin:

else ifeq ("zorin",$(OS_NAME))

Set it as Zorin instead of Ubuntu and try installing with fingers and toes crossed...

yep it does seem clear that using an AMD gpu on linux is risky. the error i'm seeing occurs before the checks for OS in the makefile, so i don't think that will help. i did find someone else with exactly the same graphical glitch, and the same error trying to install amd gpu drivers, and they posted some commands that fixed it for them, at the end of this post:

unfortunately those 4 commands didn't fix it for me. maybe my only option is to go out and buy an NVIDIA card..

You may switch back to windows if you have issues with money, there is no need for a new gpu. The primary reason people switch to linux is they want to make their PC faster, If you are facing any problems. You might consider windows as another option rather than buying a gpu.

Btw the output for,

dmesg | grep -i amdgpu


lol no chance ghostminator. i choose linux because it is open, doesn't contain spyware, is a reliable and solid OS, and has great community support. Windows is the exact opposite of all of those traits. And Zorin is the best distro for me as it's user-friendly. I'm happy to buy a GPU to avoid Windows.

1 Like

in tty this command returns nothing i.e. there is no mention of amdgpu in dmesg output.

That means no driver is installed.
In this case, you can try