Crashed Libre Office

I suppose this is really a LibreOffice problem but I’m wondering if anyone has had problems with it recently. This morning Libreoffice Writer was working fine; odt files opening and reading ok. There was a Zorin update today that I downloaded. This evening, I received a docx file from a friend via email, which I was expecting; so I saved it to my desktop and then tried to open it.
LibreOffice Writer began to open up then stopped and presented me with a little white box with an X in it. Having closed it, I then tried to open some of my other odt files…and they all did the same thing. I can’t open the application now or read any of my odt files in it. This is only affecting Writer.
Having hunted around a bit, I discovered the command line for starting up LibreOffice Writer; and this is what the terminal produced:

christine@christine-XPS-8930:~$ lowriter
javaldx: Could not find a Java Runtime Environment!
Please ensure that a JVM and the package libreoffice-java-common
is installed.
If it is already installed then try removing ~/.config/libreoffice/4/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx

I have to say that all the LibreOffice packages came with my Zorin Ultimate 15 and I haven’t fiddled with them at all since I installed the OS.
With regard to the terminal message, where would I find libreoffice-java-common? so that I can check whether it is present or not. Secondly, where would I find the other .config libreoffice file mentioned?

If the .config file is not showing in your home folder, hit ctrl+h
When you navigate to ~/.config/libreoffice/4/user/config/
do you see the javasettings_Linux_*.xml file? I just looked in mine and that file is present.
If you see it, delete it or move it to trash, then log out and back in and see if that helps to resolve the issue.

Thanks for that quick reply; I’m just about to eat (late tea!), so will check out your advice a bit later.

Yes, there was a Linux .xml file present. I’ve moved it to the rubbish bin for now. I have logged out and back in again, and bingo, the odt files are opening. Goodness knows what caused all that mess.
Out of curiosity I also opened the application via the terminal. It again put up the Java Runtime message, but the application opened anyway and appears to be functioning normally.
Fingers crossed, this has nailed it.

You could (hopefully) update to 6.4 - its in the software channel and is the most recent stable release - if you scroll-down you will see reference to 7.xx but this latter version is only Beta and extremely unstable! I know because FerenOS appeared to be pushing it through its repos so I ‘downgraded’ to 6.4. :wink:

Mine seems to be 1:6.3.5 and that’s from the Zorin collection.

hmm…
Mine is 6.4.5.2

A post was split to a new topic: Installing / upgrading LibreOffice

It’s easy enough to install from Software - if you search for libreoffice it will show all your apps installed with an additional ‘libreoffice’ app at the top. Just install that and you will see a new set of Libre Office Apps in your menu with 6.4 at the side. You can then safely remove the other apps from Software channel by selecting the app then select uninstall or remove button - usually the red one!

how to install third-party app’s like this one GBWhatsApp a modified version

GB WhatsApp App specification you can check here https://gbapps.net/gbwhatsapp-apk/

Welcome to the forum, johnamaro.

The whatsapp application you referenced is an .apk file, which is for Android Operating Systems.
You can run those from your PC using an Android Emulator, but cannot install them to your PC (Windows or Linux) as is.