Dark Mode Bug

Hi guys,

I am a new Linux user that wanted to change from Microsoft and currently I'm experiencing an issue with my Zorin OS installation. It seems like some applications have a white "Background" even if I am using Dark Mode.

Do you know what might've caused this issue? Attached are some screenshots from the Calculator and the Software Center. Also seems like the Calendar has a very hard to read font color as well.


Tags: Zoringroup : Zorin Theme Font visibility issue (EDIT: Tags removed as not a Zorin Theme Issue)

In the meantime, @SkyDream , can you help us in Testing to ensure narrowing down this issue? Try a Different Independent Dark theme (You do not have to like or keep it) and see if the Backgrounds appear more normally. If they do, then we know that this can be easily fixed within the Zorin theme.

Just tried to use the Mojave Dark theme and the Arch Dark theme and it seems like the same issue occurs.

Also, just wanted to add that this issue just started to happen 2 days ago, it was good until then and after a restart, it seems like that happened.

Can you post a screenshot of your Zorin Appearance Settings?

Sure thing, here are some screenshots. I just restarted to the default style.

Do you think it might have something to do with the styles.css? I've tried experimenting with some Desktop Environments that I didn't like so I just uninstalled them, I think that while doing that some config files might've changed. I tried installing the KDE Environment and the Deepin one. None of which was a good match for me

I did initially... But now I have doubts.
If it was in the .css, you would have seen that change when you changed themes.

Was this issue present prior to trying other Desktops?
IF not, then we have a likely cause.

When it comes to trying out Plasma 5 or Deepin or some other desktops on Zorin; Synaptic is Essential.

sudo apt install synaptic

Now that it is installed, you will find a very Handy Tool in Synaptic for the event of if you decide to remove Plasma Desktop. Simply removing the Plasma Desktop will not remove most of it. For this, open Synaptic
Then from the search bar; search for plasma
Mark any packages for Plasma desktop that are listed as installed for complete removal.
Search KDE
Repeat this with any KDE packages.
Click on the Apply Button when finished.

Perform the same for Deepin.

This issue was not present before trying other Desktop Environments. So I think that might be what caused this to happen.

For KDE I have a lot of packages, I removed the Deepin ones and the Plasma ones. Should I ho ahead and completely remove all of them from KDE?

This is what I have:

Thank you so much for all of your help so far and I do apologize for the hassle.

Yep, let's clean house. Remove all KDE applications, settings or Configurations - the Same for Deepin.
Once finished in Synaptic, open your ~/.config directory and search through, looking for any KDE or Deepin Specific configuration files that can be moved or removed.
Reboot and test - or if you want to go above and beyond, reinstall the Zorin Desktop (his will not change your personal settings) to ensure that it is the priority

sudo apt install --reinstall zorin-os-desktop

then reboot and test...

Just tried all of the steps provided there, and seems like I still encounter the same issue. I reinstalled the Zorin OS Desktop as well.

Here is how the .config folder looks like now:

I'm not sure if any of the Desktop Environment that I've tried changed any style config that was initially set up by the system. Also, sorry for the bad English. It's a new territory for me (Linux Desktops) and I am trying my best to learn it as much as possible.

Every file starting with "k" can go in the trash.
Also, plasma-localrc

I need to leave the computer for about an hour and a half.

Thank you so much for all of your help so far, seems like that didn't fix the issue yet.

Is there any command that can restore the default config files for the Zorin Desktop Environment? Maybe that will fix it. Also, can you please recommend a good back-up solution in the future if I would like to experiment with other Environments? That way I can prevent this from happening in the future if I will have a system back-up in place.

Again, thank you so much for all of your help so far! I really appreciate it.

There is something you can do to reset User configurations:
Rename your ~/.config directory to .config-bkp, log out and in to get default configs on everything. From there, you can move any configurations you know are good and wish to keep into the New Defaulted .config directory.

1 Like

Deleting the config folder fixed the issue for me. Thank you so much for your help with this, could you please recommend me a good backup software to use in the future? That way I can revert if something happens.

Most users seem to prefer using Timeshift for back-ups.
I prefer to do all my back ups manually.

1 Like

Thank you once again for all of your help! Really appreciate it

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.