Dell latitude 5480 and boya by-m1

Hello brothers,
I have Dell latitude 5480 laptop core i 5 Gen 7th HQ when I connect the microphone which is Boya by-m1 and I start recording it has a lot of noise , can I have quickly help please

Also I tried these
sudo nano /etc/pulse/

load-module module-echo-cancel

This user found that he needed to take out the battery and place it back in...

1 Like

Gday @sma_coding, Welcome to the community!
A faulty/weak/bad battery can cause a static/hum/squealing noises.
Also a faulty charging board, due to faulty battery/etc.

If the battery is ok, try recording without the charger plugged in, Or try removing the battery & run on AC only.
Also double check the plug on the microphone is fully pushed in.

Let us know how you go.

thanks Ocka

yesterday I tried the same mic on H.P ELITE Book it worked will

today when I get home I shall try to stop using the AC cuz the battery is built in the laptop I hope it works

but what else can I do if it doesn't work

Is the 3.5mm jack on the Dell dual purpose mic+headphone?

You could from terminal run alsamixer
have a play with the "loopback" channel setting i.e. try both enabled or disabled.

Also try

sudo ubuntu-drivers autoinstall



Just a follow up on Ocka's post.
Make sure your Software Updater points to "Main Server" not a local/regional server for best results.

Made me think,
Also look in alsamixer or audio pulse, & turn down the " Boost " on the mic, then adjust the mic level to suit.
Hope this may help

I'm offline, Bed time :smile:

1 Like

I tried everything nothing new

Could you please tell us the spec's & age of the laptop?
Are you dual booting or clean install?
Do you have another mic to test with?
If so try the 2nd mic in the laptop concerned.
Do you have a usb/3.5mm adapter to test for a faulty port?

Please open HDA jack retasker, set the port to Override.

First thing first thank you from the bottom of my heart that you try to help me

secondly sorry for my weak English

Thirdly about the laptop..
it's August 2020 production
Dell latitude 5480
core i 5 Gen 7th HQ
8 Giga ram ddr4
it has type c port (I don't know what does it mean)
three 3.0 USB ports
it's built in microphone, I tried it there's no noise with it but the sound not professional as Boya by-m1 microphone

about the 3.5 adapter or USB I don't understand it (sorry for my weak English)

I use Boya by-m1 microphone on hp elite book 6930 15 yrs old laptop with no problems

inxi -Fxxxrz
Kernel: 5.15.0-67-generic x86_64 bits: 64
compiler: N/A Desktop: Gnome 3.38.4 wm: gnome-shell
dm: GDM3 Distro: Zorin OS 16.2
base: Ubuntu 20.04 LTS Focal
Type: Laptop System: Dell product: Latitude 5480
v: N/A serial: Chassis: type: 10
Mobo: Dell model: 07W359 v: A00 serial:
UEFI [Legacy]: Dell v: 1.4.3 date: 05/11/2017
ID-1: BAT0 charge: 31.8 Wh
condition: 32.6/32.6 Wh (100%) volts: 8.1/7.4
model: SMP DELL GD1P653 type: Li-ion serial:
status: Discharging
Topology: Quad Core model: Intel Core i5-7440HQ
bits: 64 type: MCP arch: Kaby Lake rev: 9
L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2
ssse3 vmx
bogomips: 22399
Speed: 800 MHz min/max: 800/3800 MHz
Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Device-1: Intel HD Graphics 630 vendor: Dell
driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:591b
Display: x11 server: X.Org 1.20.13 driver: modesetting
unloaded: fbdev,vesa compositor: gnome-shell
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2)
v: 4.6 Mesa 21.2.6 direct render: Yes
Device-1: Intel CM238 HD Audio vendor: Dell
driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:a171
Sound Server: ALSA v: k5.15.0-67-generic
Device-1: Intel Ethernet I219-LM vendor: Dell
driver: e1000e v: kernel port: f040 bus ID: 00:1f.6
chip ID: 8086:15e3
IF: enp0s31f6 state: down mac:
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
v: kernel port: f040 bus ID: 01:00.0
chip ID: 8086:24fd
IF: wlp1s0 state: up mac:
Local Storage: total: 238.47 GiB
used: 20.87 GiB (8.7%)
ID-1: /dev/sda model: 256GB size: 238.47 GiB
speed: 6.0 Gb/s serial: rev: 71E0 scheme: GPT
ID-1: / size: 59.28 GiB used: 20.87 GiB (35.2%)
fs: ext4 dev: /dev/sda1
System Temperatures: cpu: 47.0 C mobo: 26.0 C
sodimm: 22.0 C
Fan Speeds (RPM): cpu: 0

Processes: 235 Uptime: N/A Memory: 7.39 GiB
used: 872.1 MiB (11.5%) Init: systemd v: 245
runlevel: 5 Compilers: gcc: 9.4.0 alt: 9
clang: 10.0.0-4ubuntu1 Shell: bash v: 5.0.17
running in: xfce4-terminal inxi: 3.0.38

Dell website states the 3.5mm jack is "Audio Combo Jack", so answer = Yes.

So where's the answer to the problem
I know the audio socket is used for both mic and hand free

In your Zorin>Settings>Sound. What do you see there for input device/s when mic plugged in. Post a screenshot.

Also a screenshot of your alsamixer would be of interest, but hit [F5] to show all sound channels first.

I am wondering ifjackretasking would do the trick for you, but I have never used that myself. Maybe someone else on the forum can help.

All of that has no use
But thanks alot

could any one help in plain words plz

@sma_coding , have you followed these steps, yet?

From that screen in terminal, can you please tap the F5 key?