Dell Precision 5750 - No sound ( Dummy Output )

Hi everyone!

Got a new laptop last week and have been dying to try out Zorin OS,
Everything has work out great except that I have no sound at all!

I tried a couple of suggestions from the forum and also from different generic ubuntu threads online but to no good, I tried so many suggestions i dont even know what i tried in the end. I also tried Live-CD (No sound), wiped everything and installed Ubuntu 20.04 (No sonud), wiped everything and installed Windows (came preloaded originally) - Yey sound… Bleh. Windows… Well at least its nyt a physical issue.

Now i’m back on a fresh install of Zorin OS (Core) with dummy output! :slight_smile: Any pointers on where to start troubleshoting this sound issue?


Adding output from inxi

dator@pet:~$ inxi -SMA
System:    Host: pet Kernel: 5.4.0-66-generic x86_64 bits: 64
           Desktop: Gnome 3.30.2 Distro: Zorin OS 15.3
Machine:   Device: laptop System: Dell product: Precision 5750 serial: N/A
           Mobo: Dell model: 0GHJ21 v: A03 serial: N/A
           UEFI: Dell v: 1.4.0 date: 09/03/2020
Audio:     Card-1 Intel Device 06c8 driver: snd_hda_intel
           Card-2 NVIDIA Device 10f9 driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k5.4.0-66-generic

Could the issue be that Zorin detects another “sound card”… NVIDIA?


Alsa-mixer is not showing any master, speaker, headphone etc

I do not know if the walkthrough in that article will help or not- but I would be happy to find out. The Author suggests he tried many things, as well.


I’m following this guide now,

dator@pet:~$ lsmod | grep snd_hda_intel
snd_hda_intel          49152  2
snd_intel_dspcfg       24576  3 snd_hda_intel,snd_sof_pci,snd_sof_intel_hda_common
snd_hda_codec         135168  3 snd_hda_codec_hdmi,snd_hda_intel,snd_soc_hdac_hda
snd_hda_core           90112  7 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_sof_intel_hda
snd_pcm               102400  8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_core,snd_hda_core,snd_pcm_dmaengine
snd                    86016  15 snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_rawmidi

and then…

dator@pet:~$ lspci -nnk | grep -A2 Audio
01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:10f9] (rev a1)
	Subsystem: Dell Device [1028:0990]
	Kernel driver in use: snd_hda_intel

Why is only “NVIDIA” showing…?
According to dell specs:
Dell Precision 5750 Technical Guidebook (

Anyway, continuing the guide with…

echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf

Rebooting and freeze black screen. Only way is to turn off with power button at which point screen lights up and I can for a split second read something like “snd_hda_intel” No response from codec, resetting bus…

Had to boot up from Live USB and mount partitions there to remove this options from alsa-base.conf

Not sure how to proceed from here.
Any thoughts?

Well, I just tested a quick search on this issue using a variety of keywords. I only have a couple posts from you to make a judgement on; but it seems to me you are no slouch with commands and terminal.
And I am aware already that a patched kernel was released due to a bug in the initial kernel released with Ubuntu 20.04- If you installed 20.04 recently and had the same issue after a sudo apt -dist-upgrade, it seems like a goosechase to pursue the kernel- barring rolling the kernel Back, a ways, that is.

I think it is likely you tried the normal fixes like reinstalling alsa and pulseaudio and installing pavucontrol and checking mis-configurations.

I could be Wrong… But it also seems like I am seeing a lot of Intel Issues, lately.

I am leaning toward Intel.

Can you post a Screenshot of the output of

sudo nano /etc/modprobe.d/alsa-base.conf

Thanks Aravisian,

Actually I only tried 20.04 “out of the box”, not with dist-upgrade… i realize now that was a rookie mistake. Maybe i should try another run at pure ubuntu just to make sure that the sound doesn’t work after a full dist-upgrade?

Yeah I tried most common things as reinstalling pulseaudio and alsa (generating new configs etc)

Here’s a dump from alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

It’s pretty much autogenerated at this time, cause i’ve removed all options that i tried that didnt work! :slight_smile:

Let me know if you find anything odd about it, otherwise I might try the full dist-upgrade on ubuntu 20.04 and see if that gives me some sound

That you have modified that file before does not give me much hope.

Can you also dump

sudo nano /etc/modprobe.d/blacklist.conf

Have you added to the end of /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=clevo-p950


Heres blacklist.conf

# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# Causes trackpads to stop working on Lenovo 11e 2nd gen (Ubuntu: #1802135)
# and Lenovo x240 to hang on boot (Ubuntu: #1802689)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac

I hadn’t tried cleo-p950 but I did now
Added it, alsa force-reload, rebooted, but alas - no sound :frowning:

Call me crazy, but try running

update-initramfs -u

and reboot and test again before altering your alsa-base conf back to how it was before…

Not sure if these warnings indicates something but doesnt really seem to be connected to audio

 dator@pet:~$ sudo update-initramfs -u
    update-initramfs: Generating /boot/initrd.img-5.4.0-66-generic
    W: Possible missing firmware /lib/firmware/i915/tgl_dmc_ver2_04.bin for module i915
    W: Possible missing firmware /lib/firmware/i915/skl_guc_33.0.0.bin for module i915
    W: Possible missing firmware /lib/firmware/i915/bxt_guc_33.0.0.bin for module i915
    W: Possible missing firmware /lib/firmware/i915/kbl_guc_33.0.0.bin for module i915
    W: Possible missing firmware /lib/firmware/i915/glk_guc_33.0.0.bin for module i915
    W: Possible missing firmware /lib/firmware/i915/kbl_guc_33.0.0.bin for module i915
    W: Possible missing firmware /lib/firmware/i915/icl_guc_33.0.0.bin for module i915
    I: The initramfs will attempt to resume from /dev/dm-2
    I: (/dev/mapper/zorin--vg-swap_1)
    I: Set the RESUME variable to override this.

Reboot but no change. Still Dummy Output and missing profiles in alsa mixer

It’s possible, but I see those warnings often enough with no audio problems and usually, they seem harmless. Harmless enough, anyway.
Have you tried updating grub to

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash snd_hda_intel.dmic_detect=0”

I don’t want to interfere with the diagnotics conversation you two are having, but there is a post (including links) on here by @swarfendor437 re dummy output saga, that may be sof interest: Headphones showing working, but no sound at all - #3 by swarfendor437

1 Like

I, for one, appreciate any and all help.

Alright good!

I tried now, i’m no grub expert but added it to etc/default/grub and did update-grub
Reboot, no change.

Thanks for the tip!
I have tried the first two articles but to no avail.

I’m curious as to the last one ( How to get a SoundBlaster Audigy Rx to work in your system! ), which seems interesting, because the system lists me as having two soundcards (Although i only have one, i’m pretty sure).

The first command from the article should list the “duplicate cards”

nano /proc/asound/modules
This just results duplicates for me…

0 snd_hda_intel
1 snd_hda_intel

I wonder how i could go about one card that uses the same module?

Had you removed the clevo950 whatever from the /etc/modprode.d/alsa-base.conf, first?

There are four “solutions” discussed in this thread and I recognize one as one you tried already, but This one may be of interest- especially as you listed duplicates above:

load-module module-alsa-sink
load-module module-alsa-source device=hw:0,2

I tried with and without :slight_smile:

This is didnt work, although the “dummy output” disappeared in Sound settings. Checking logs i see pulseaudio failing

dator@pet:~$ pulseaudio 
E: [pulseaudio] module.c: Failed to load module "module-alsa-sink" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

I also notice this in journalctl

> feb 24 08:06:10 pet kernel: Kernel is locked down from EFI Secure Boot mode; see man kernel_lockdown.7

Probably not related…?

Actually, could be related.

Do you have Secure Boot enabled in your UEFI?

Yes it’s activated. The computer came pre-installed with windows and i had to do lots of scary stuff to get rid of it, such as disabling (although temporary) secure boot and even switching from raid to ahci(? something), just to be able to get rid of all windows partitions… maybe i something there… :slight_smile:

Well, thar’s yer problem!

You are actually the second person I have ever spoken to that managed to get Linux installed while secure boot was enabled at all.

The word “secure” is a bit of a misnomer, in this. It is not a security issue, well it could be a security for Microsoft preventing any other OS issue… But Secure Boot does not protect your computer.
Otherwise, you would need a password to boot.

To install Linux, any distro, Secure Boot must be disabled.
If installing alongside Windows, Fast Boot must also be disabled.