Dell Precision 5750 - No sound ( Dummy Output )

I had no idea! I thought even the OS-installer asked to activate secure boot (Because of third party software etc)?

So moving forward I could try to make sure Secure boot is disabled in BIOS and then reinstall from Live USB?

That is what I would try.
I have installed Zorin many times and I do know if it asking to install third party software, do not remember it ever asking me to Enable Secure boot…
But as an aside, I always recommend installing with the Third party and Update during installation box Unchecked. Even connecting to the web is unnecessary. Do the installation First, then once it is complete and rebooted, run the updates and upgrades, after. IF you want to use proprietary drivers, install or enable once all upgrading and installation and the like has been done.

To totally jinx us now… Watch you re-install, secure boot off, all advice taken and sound still not work… -shrug- 2020 ain’t done with us, yet.

These tips are greatly appreciated Aravisian, and thanks for all the help so far (With your jinx in mind i had to add “so far”)

Will update here as soon as possible on the outcome of re-install

1 Like

No luck,

Installing with secure boot turned off was successful, the kernel lock previously noticed in journalctl is gone but so is sound.

Would you suggest i go through all the previous steps again (without kernel lockdown this time)?

I also found this neat script that lists my audio stuff…
https://termbin.com/adof

It is seeing your sound card, given the link you posted.

If it was me, I would try the real simple stuff, first - like pavucontrol, settings…

It’s a shame your computer is not Perseverance powered. You could run the thing off the grid for months.

Given what you just posted, can you dump

sudo nano /etc/pulse/default.pa

You may need to add a line to it. Looking at your link above:
Module #8
Name: module-alsa-card
Argument: device_id=“0”

Adding to /etc/pulse/default.pa the following MAY help

load-module module-alsa-sink device=hw:0,0

It would probably outlast us all

Here’s a dump from default.pa
https://termbin.com/glqo

From that, these two lines are commented out:

#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0

I wonder if you uncomment them, will it help

Unfortunately no,
Uncommenting those make pulseaudio unable to start…

dator@pet:~$ pulseaudio
E: [pulseaudio] module.c: Failed to load module “module-alsa-sink” (argument: “”): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.
dator@pet:~$

How do one actually determine what driver should be used for a soundcard? How do i know snd_intel_hda is the one i should use?
Edit: Reason i’m asking is because I booted up Ubuntu from a live usb and it loads snd_soc_skl_hda_dsp instead of snd_hda_intel.

cat /proc/asound/cards

dator@pet:~$ cat /proc/asound/cards 
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0x609b218000 irq 212
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0x73000000 irq 17

mkk says:
" I am running Ubuntu 20.04, on Dell Vostro 7590 with kernel version 5.6.0-1020-oem.

Here is what solved my problem.

  1. Install SOF firmware and topology binaries:
git clone -b stable-v1.5.1 https://github.com/thesofproject/sof-bin.git
cd sof-bin
sudo ./go.sh
  1. Blacklist snd-hda-interl and snd-soc-skl by adding following lines to /etc/modprobe.d/alsa-base.conf:
blacklist snd-hda-intel
blacklist snd-soc-skl

Note that if you have some other changes to that file, it is good to revert them (e.g. remove options snd_hda_intel dmic_detect=0).

  1. Reboot"

Aravisian,

The SOF firmware was a good lead, thank you.
It led me further more to this blog post about the Dell XPS 2020 with same sound card as precision 5750. Apparently its a know issue on XPS 2020 that sound isnt working…

https://blog.fts.scot/2020/07/04/dell-xps-2020-how-to-get-audio-working-on-linux/

I checked out the patches posted there (and actually took a swing at upgrading to kernel 5.8), and believe it or not I have sound! At least from my 3.5mm jack. Still working on the speakers

But all in all i’d call this a win!

1 Like

Another suggestion might be to try Devuan, Antix or MXLinux- a Non-Systemd distro.
Systemd uses these Modules that you are experiencing difficulties with. I wonder if you would have a very different experience with a different init system.

Good idea,
That might actually work but then i’d loose the benefit of running this lovely OS.
I got speakers working as well now, it was just a muted layer in alsamixer.

I spoke with Dell this morning and they suggested the SOF firemware as well (Mentioned in the blogpost i linked), so this seems like a valid resolve.

@dpet8 Wow. Now you are talking Good News!
I have had a long running battle with intermittent sound on Zorin as my friend @Aravisian will be very familiar. In short, every time I booted Zorin, it was a lottery if sound worked or not. A few days ago I got the silent treatment from Zorin. My usual remedies via pulse audio and alsamixer controls failed me. Then I found setting on alsamixer for “Loopback” at far right. I had a play with that and sound came back, initially as deafening feedback tone. After I turned down nearby sliders, that receded and sound still worked. I saved the alsamixer setting using:

sudo alsactl store

Sound still works (so far anyhow) after many a reboot and even after a kernel update today, things that would regularly stop it before. Maybe I have said this before, but sound on Zorin(Ubuntu) seems more witchcraft than science. I continue the habit of crossing fingers every boot and testing speakers thereafter.

I hope you now get your speakers, headphones and microphones all working as expected.

1 Like

True, and honestly, I dread seeing the infamous “sound problem” in the title of a new thread.

Yeh. I thought it was just me :hear_no_evil:

Has anyone fixed this problem