Desktop Freezes randomly

  1. CPU and Memory always remains below 50%. There is no resource hungry app running.
  2. In additional drivers section, there is only one intel network driver. (I am Ryzen user)
  3. I haven’t enabled it
  4. *-display
    description: VGA compatible controller
    product: Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
    vendor: Advanced Micro Devices, Inc. [AMD/ATI]
    physical id: 0
    bus info: pci@0000:03:00.0
    version: c4
    width: 64 bits
    clock: 33MHz
    capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
    configuration: driver=amdgpu latency=0
    resources: irq:53 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:fe700000-fe77ffff

I have fairly good 1 year old notebook with 8GB of RAM. This much should be enough for web browsing or document editing.
Here I am uploading complete report of my computer.
Click here to see report

Update : Sometimes, when rebooting Notebook after Freeze, it redirects to busybox which shows filesystem error. I bypass it everytime using fsck /dev/sda4 -y
My friends discovered this issue in lite edition also.

Can you use Synaptic to tell us if you have the following packages installed?

  1. xserver-xorg-video-radeon-hwe-18.04
  2. mesa-va-drivers
  3. mesa-vdpau-drivers
  4. mesa-vulkan-drivers
    If any of those 4 are not installed, please install them.

If this still doesn’t help, in terminal (ctrl+alt+t), please run sudo add-apt-repository ppa:oibaf/graphics-drivers and then sudo apt update && sudo apt upgrade

All the 4 packages are installed but i am still getting freezes, sometimes back to back.

Whenever desktop freezes, it disconnects me from meeting. Restarting whole process wastes important 5 minutes.
For document editing, there is less pain because of document-recovery feature of libreoffice.

Just remembered that I get occasional lock-up’s on Core. I have always got out of them by attempting a log-out, but not actually logging out.
The appearance of the log-out/switch user window seems to revive the session.
I think I get to the log-out screen using Ctrl+Alt+Del or something when screen is frozen. I’m not on Zorin right now to test that.

Please be mindful of your posts. I have bolded the part of your response that is disrespectful toward another poster and thereby a violation.

I edited my post.
However, my intention was not to disrespect to the person who is trying to help me.
I use those words for irritating desktop freeze problem which occurred since zorin 15.1

I tested all key combinations.
There is variation on type of freezes that occur.

  1. Mouse scroll moving but no action can be triggered both from mouse or keyboard.
  2. Screen completely freeze but reboot again get it working.
  3. Screen freeze and after reboot it redirects to busybox where i need to solve disk error using fsck /dev/sda4 -y

Every desktop on which i installed is getting at least one type of freeze. I can’t understand where the problem is.

Some more suggestions here:

  1. Some suggestions on BIOS settings:
  2. and also
    I noticed disabling dpms among the many suggestions. I know yours is a laptop but see if disabling the blank screen does anything. There are other suggestions you can try here too but the kernel one doesn’t apply and oibaf was already tried by you.

I read your suggestions and tried them as well.

  1. Updating Kernel
    I am already on kernel 5.4
  2. ctrl+alt+f1 & ctrl+alt+f7 both tried during freeze, none works. Moreover, in 3rd type of freeze even Magic SYSRQ fails to respond.
  3. I have no problem running fsck but the thing is that disk blocks are getting damaged or duplicated + it takes lot of time.

This is something which should not happen. Why file corruption in between performing simple tasks?
There exists BUG!!

After some more research, i found this post

It exactly resembles my problem. Exact logs and exact laptop model. He mentioned that he is getting such errors in other notebooks also using Ryzen 2500u even in different linux distros.

Yes, i sometimes hear fan speed to increase too much, but this happens rarely, remaining it freezes without making noise.
My laptop is just 1.5 years old and still under warranty of two years.


Can you give the output of lspci ?

darpan5552, I have not been experiencing many of these issues and I have tried to replicate a few.
I am using Zorin Lite- loaded up with Cinnamon (Embroysn) desktop environment.
I also installed Mate- for testing and formatting- several months ago.
So that gives me Zorin Lite Desktop (XFCE), Mate and Cinnamon to play around with.

I do have Zorin Core (Gnome) Installed on another partition, too. I booted into that and had no problems, even while running 16 browser tabs, Inkscape, Gimp, and Audacious all at once.
And, I got tired of testing. I figured give up, try another day, went to the menu to select Restart- And it froze.
-shrug- I kicked back and let it sit- to see if the processor would catch up, RAM clear out and get Unfroze. Eventually, after trying different things, I did a Button-Press (Hard) restart.
I repeated the experiment this morning and when it froze, I tried restarting Gnome-Shell from terminal and while it took a long time to get that done, the computer was operating normally after that.
I restarted, normally, and booted into my Zorin Lite OS. Which is where I plan to remain (I only have the Core Partition for testing).

It shows a possible Common Denominator, nothing more. A hint as to what direction to look at. But… I also had noticed that on my normal machine, when I upped gtk from 3.22 to 3.24 (built from source), I have had no freezing since then, either.
I do not use Gnome, but I do use gtk.
The suggestion in all of it is that it is likely that Zorin 16 will carry much less of this issue and it also suggests that newer Distros and kernels will not run older machines as well as they used to just a couple of years ago.
Clues- we are just following clues, right now.

1 Like

Currently, i am investigating logs each time i am getting a hard crash.
In second attempt, i found a problem that is common to many AMD users, the infamous “Ring gfx timeout error”

Also, some people are getting relief by setting amdgpu.noretry = 0 as mentioned in below sources.

Output of lspci

Thanks. I was wondering if you had 2 GPUs as that may have been a cause but nope.

A post was split to a new topic: Zorin OS 16 Core random freezing on Nvidia

3 posts were split to a new topic: Zorin OS Pro freezing and crashing