Desktop Shortcuts all open text editor

Hi there!
Ok, I don't even know where to really start on this one. My brain is mush at this point, as I've been messing with this all afternoon.

I have slowly but surely getting things to work correctly on my Linux drive. Today was a tough one. I have several hard drives on this machine. One of them has my movies and shows on it, one has my Steam games, and another has different games and emulators. I use snes9x, kega fusion, dolphin emulator, etc.. I have shortcuts on my desktop to each of them and until today, all of these apps worked just fine.
Problem is, when I would try to get something ELSE working, another something breaks. Such was the case today, where I was playing with permissions, trying to get an app to be able to see my drive. At this point I have no idea what I did, but now all the desktop icons look the same and just open the text editor when I try to run anything. If I make a new shortcut to an app, it does the same thing as well. Opening an app from elsewhere, like the launchpad, or taskbar works fine. But the desktop shortcuts are all borked.
I am so lost at this point, I could almost cry. I've been working so hard on this because I really do enjoy linux, and ZorinOS in particular. But now I just want to set the whole damn thin ablaze and use said fire to light my joint. I'm done. lol

I have looked and looked and looked online, but everyone in the know assumes we all know what we're doing. I do not. I haven't touched Linux (until this build that is) in 20 years and even then I was new at it and didn't use it very much outside of school. So I don't have a clue what to do here. PLEASE HELP ME????

When I first migrated from WIndows to Linux, I felt the full brunt of this, too... as well as me learning by doing which often resulted in massive frustration, wanting to go back to Windows and... Many, many re-installs of Zorin OS.
I have no idea what happened, either. I am actually even having trouble picturing what you describe. Perhaps more persistence in this thread can tease that out. Perhaps you are on the road to a fresh start and ... having the "fun" of redoing things you already configured.

The reality is, though - redoing things is a great teacher. And once we hurdle it, we often feel a lot better than we felt when looking ahead to the prospect.
Maybe this first reply is not bearing a solution. But...

You got this.

You're gonna get through it.

Before long, you will know what you are doing.

Now... are you able to post screenshots to help your description?


Try Right click the icon select Properties,
Click the "Open With" Tab, Click "reset" in bottom Left corner.
You will need to do this to other icons that have different directories.
Hope this helps.


It happen to me when I installed a program trough Wine. It was text on desktop. Then I went to all aps and look for that program icon. Right click on that icon and add to desktop. It replace the text with icon and you can run that program. That was my experience - it may help you

1 Like

Thank you for the encouragement. Had to take a break for a couple days lol :wink:

Here is a screenshot... I just created a desktop shortcut for Dolphin Emulator. It USED to say "DOLPHIN" and you'd click it and it would run. But now it says like, org.dolphin.desktop or something and when you click it, it opens the text editor as you can see there.

Also in the screenshot are the permissions I was screwing around with in the terminal. If anyone can see anything out of place, please let me know!

I just tried that as you mentioned. It did nothing, sadly. But thank you anyway!

1 Like

Thank you. Yeah, when I do that, it just creates another icon like you see in my screenshot and wants to open in text editor.

It looks like you were changing ownership of Root to home. This should never be done and there is no need or reason to do so.
This also may mean that applications looking for their target under root permissions will not find them.
Everything else looks normal, even the Dolphin name. The change caused the name to be displayed by a differently owned configuration file other than your home ~/.config location, I suspect.

Have you yet returned root ownership to root?

sudo chown root:root /


Ok Right click the desktop icon, select permissions tab & check the " Allow executing file as program ".
Hope that helps

good morning! I woke up, saw your reply and raced down to the computer to try this. Sadly, even after a reboot, the issue is still here. However, I do think you are onto something because I was screwing with a lot of permissions.

See, how this all started was when I was trying to load a game in one of my emulators. Now, I know it worked before. But somewhere along the line things got messed up. For example, if I now go into snes9x and try to open a game, there is nothing showing. But if I go to my file explorer I can see the roms in there just fine. So when I read up on it, it said there must be a permission issue and that the app no longer has permission to view the folder. This is what I was trying to fix.
So maybe, you can tell me how to undo what I have done, and then do it right? lol
I have included a new screenshot and if you need specific ones, just tell me.

1 Like

Thank you. Yes I have done this as well, to no effect.

1 Like

Yes; it is very helpful that you premised this thread with what you did before the problem began. Many don't. Maybe they do not remember or do not think it was important.

Permissions are a critical thing and must be exercised with caution. Especially if the recursive flag (`-R) is used.
I saw above that you included a :users permission, as well... I wish I knew a "Restore all permissions to default" command that was simple. Sadly, we would really need to know each change you made - than trace it backward undoing each one in order to be thorough.

Your best bet is to reinstall Zorin OS. As daunting as that sounds, please first see this thread to see if you can make things less daunting.

1 Like

While I am not apposed to reinstalling if need be, that's really gonna be a last resort as this was incredibly tedious and tricky to get set up how i like it. I will try and undo a few more permissions first. Hopefully that helps.
Quick question (yeah..."quick"...sure lol): Lets go back to the beginning. When my emulators stopped being able to find my games, what should I actually do to fix that? FYI, dolphin was not affected. Of course I am aware that I was mounting the drives to a new place, but in Dolphin, I just had to point it to the new location. On the other emulators, that location won't even show up! Remember /media/tes/games? (in this case)
When I try to open it in, say, snes9x or kega fusion, it's not even in the list. Point of fact, even though it's in the /home directory, it doesn't show up in the emulators. (see screenshot)

As you can see in the above screenshot, the folder "games" shows up in file manager but not in the emulator search. This was what started my trip down misery lane, and caused the severe drinking problem that has haunted me since last Sunday.

I will tell you that I changed permissions for each of my hard drives, remounted them umpteen times till I finally mounted them all in /media/tes/drive-name. Now they all show up by NAME instead of the drive designation.

If I DO have to re-install, is there a way I can back up my apps and settings first? I downloaded "Back-in-time" but I don't really know how to use it lol.

1 Like


You can save your entire ~/home directory if you want to.


Hi there. Well, I just wanted to thank you (and everyone else as well!) for all your help. Try as I would, I had to reinstall. I just could not get it fixed.

I have my install now about 80% the way I had it. I have my various drives all mounting to /mnt/sdX (X being whichever drive).
My icons all work now, of course, I have backed up my repos, and I am currently backing up my system using Timeshift.
I am doing so now rather than AFTER I get it set up completely because I have already encountered an issue. This time I am asking for help BEFORE I screw it all up again.
With that, I am not sure if I should create a new thread or ask here. But I will ask anyway and please correct me if needed...

I am at the point where I have installed Steam and am trying to point it to my existing Steam Library which is located on another drive (sdd2 in this case).
When I did this before, I clicked the + button and the drive I needed was recognised immediately as one it could use. It was there, labelled correctly and I just had to click on it.
This time, that doesn't even happen. Instead, it opens a 'browse' window for me to search. But there is no "/mnt" to be found. If I try to point it to "/dev/sdd2" it returns an error about having to be mounted on a file-system with execute permissions. I saw that word "permissions" I just about threw my mouse at the TV after what I've one through with this thing already lol...

Can anyone tell me what I should be doing here? After I was making such wonderful progress this time, that really took the wind out of my sail.

Quick edit:
The issue which led to me screwing with permissions is also present. What I mean is when I am tryin to find my rom files on another hard drive, I have no access to said drives from within any of my emulators. Well, except Dolphin. That one seems to have no issues at all. The games drive shows up perfectly in the Dolphin game browser window. Mame64 is a little more janky, but I can at least point it to my roms, so I'll call that one 'fine' as well.

In the Disks app launchable from the App Menu, can you select the disks in question, then set them to automount:

Yes I have them all set to Auto mount already. It seems to persist correctly through reboots. Dolphin Emu and Mame can see them, but Steam and the rest of my emulators cannot. I even went through the file manager and clicked on one of the .bin files in my Sega ROMs folder and Kega Fusion launched immediately to run that game.
But that folder doesn't appear in my Kega Fusion file browser. Snes9x is the same. And Steam as well.

Do I have the drives mounting to the right place? Could it be a permission issue?

If they are mounting... it seems correct.
What about your File manager? What is your Default FM?

1 Like

Oh I don't know whatever Zorin comes with. I haven't changed it.

I do know that the games drive is NTFS and the steam drive is ext4.

I do remember when I screwed things up before with the permissions, I eventually changed one of the permissions that allowed Steam to see that drive so quickly. I just don't know what I did because I did two or three things at once and one of those other things screwed up my desktop icons.
Tomorrow when I am powered back up (I live offgrid and it's been dark and rainy all day here, so no charge) I will open the terminal and print out a list of the permissions for each drive. Maybe you can tell me if they look correct, or what I can change to allow Steam for example to execute files. Or even see the drive for that matter.

Is the package ntfs-3g installed?

sudo apt install ntfs-3g

1 Like

Morning! Ok, so, yeah. ntfs-3g was already installed.

As I mentioned , here is a screeny. I did 'ls -la' on its own (left) on the "Games" drive (middle), and on the "Steam" drive (right.
Can you tell me if the permissions are correct or what I should change them to and how?
Thank you very much again!

Incidentally, if anyone would be interested enough in this issue to TeamViewer it with me, I'm game for that, too lol

K, I've made a smidge of progress here thanks to a member on the Steam forum having the same issue. Turned out, some else with Zorin had the exact same problem and had done exactly what I did.... installed Steam from Flathub. I uninstalled that, and reinstalled from the Zorin repo instead of flathub and now steam sees all my drives.

All that's left now are the issues with my other emulators. Could it be something similar? hmm