Didnt show anything When boot with USB

I have bought Zorin16 Pro yesterday and tried to install but the screen didnt show anything. I tried the nomodeset trick in the grub config and its not working too. Safe grafic, Modern Nvidia mode, and normal mode all shows nothing. and the tty wont response too. My current OS is Windows11.

What etcher did you use to burn the .iso?
What size is the USB stick?
Are you booting the USB as EFI?
What make and model computer?
Did you check the 256sha?

I used balenaEtcher
Its a HP computer
The USB size is 128GH
The checksum match
0 idea if im booting as EFI

I wonder if it is a corrupted .iso burn. Just something to try out...
Maybe re-burn the .iso using Rufus or Ventoy and see if it works.

Sometimes, the Boot Order Selection screen will tell you:

  • Boot USB (name)
  • Boot USB (name) EFI

HP's generally work well with Linux. Can you narrow that down, a bit?


Actully I was using Ventoy at first but that als wont work...
The spec. name is HP ProBook 450 G8 with the i7 core

And yeah its booting EFI

The only thing I can think of on this is the kernel. This does not mean that is the only thing that could be the cause... Just it's the only thing I can think of.
Is it an AMD GPU?

No, its a MX450

Is the Nvidia card the only GPU?
IF it is, then Safe Graphics will not help you, since Safe Graphics falls back on the Integrated Intel GPU.
MX450 - that would be the Nvidia 495 driver, right?

Yeah, its the only GPU
I remember last time I was facing the same issue i reset the bios and it works, but it didnt work this time..

Reset the BIOS... hmmm...
Have you checked CMOS? AHCI or RAID?

I pulled out the battery for 5 mins and put it back in but still nothing
And the disk is AHCI

Have you checked for BIOS updates for your Notebook?

Its latest

Any way you can show us screenshots of your BIOS screens, especially the one of 'Boot | Boot order'. Thanks.

Switch Off Fast boot. Also make sure that you have secure boot turned off because secure boot configuration was not visible. These two may cause issues when and after you install linux.

Anyway, the reason you could not boot with the USB is because the Windows Boot Manager is at the top of the boot order. Keep "USB" at top.

I temperately boot from USB, using the util menu

Secure boot is disabled

Actully, disable fast boot some how worked but some how not worked.
After I select Install or Try Zorin
It DID show me the File checking progress bar and After that, Theres nothing. The hot keys for tty not working too. I think its hanged.
Also, earlier today, i tried to boot with ubuntu, deepin and debian. They all worked fine and boots perfectly.