Disable screen saver

I’ve only just installed ZorinOS for the first time - lite on an old netbook - and I love it. So responsive where other distros have struggled.

My only issue so far is stopping the screen timeout so the screen stays on at all times. I have tried disabling all timeouts I can find for the screensaver and power saving but it still happens.

I found a thread on the old forum that suggested running

sudo xset s 0 0

to disable timeout on xscreensaver and that works, but it reverts back after a restart.

I tried putting the command in Session and Startup, and also putting it in /etc/rc.local and setting chmod for execute but neither of those have worked either.
Any ideas welcome, thanks!

Welcome, Riyaxi.
Could you please confirm that on Settings->Power, you have tried both the Blank screen set to ‘Never’ as well as the ‘Dim screen when inactive’ toggle? Just to be sure we’re on the same page.

PS - you wrote you’re using Lite, correct? The settings may be different for you (I’m using Core) but please go ahead and confirm the exact steps, similar to how I wrote.

Hi, really sorry, I thought I set this up for notifications and missed your reply.

Under Settings > Power Manager I have tried both having “Display power management” enabled with all settings set to never, and also disabling “Display power management” completely.

For brightness reduction I have “On inactivity reduce to” set to 100% and “reduce after” set to Never.


1 Like

I just installed ZorinOS 15.2 Lite and I have the same problem. I truly hope there is a simple solution for us.

As a workround to keep your screen live all the time you could try installing Caffeine. See this thread and my reply there:


Also, under Power Manager, ensure that Sytem tab>Security “Lock screen when system is going to sleep” is UNChecked.

You might try disabling the Screen Locker
Settings > Privacy > Screen Lock

You can check the xscreensaver settings
in terminal, paste in


Screen-lock tab - Adjust as needed.


I’ll take a look, thanks. Seems odd to need an extra app though as I can get it to work as long as I don’t restart.

EDIT: Have installed Caffeine, will see how it goes!

Hi, can confirm that “Lock screen when system is going to sleep” is unchecked.

When I run


the preferences open and it shows screensaver and lock screen both disabled.

Please see here, as well:

Thanks for the information Aravisian, it’s much appreciated.

I can confirm that, for me, Caffeine works as expected and stops the screensaver coming on/screen turning off. I haven’t found a way to activate Caffeine by default yet, so for me my options at the moment - after reboot - are:

Activate caffeine
Run sudo xset s 0 0 in terminal

I think I am going to keep trying to dig into why I can’t get rc.local to work as it would be great if I could run that command on startup.

Do you have this file on your PC?

I do, yes. I only just realized that caffeine and caffeine indicator are different apps - I was activating with indicator but maybe I just need to have caffeine start on boot.

@Aravisian @swarfendor437
Update… I gave up on Zorin 15.2 32 Bit… too many things driving me crazy. I decided I would fresh install Zorin 15.3 32 Bit over it. I accidentally installed Zorin Ultimate 15.3 64 Bit over it… lol … it works… lol

I don’t understand how that can work but it is… so I will leave it for now.

I had previously installed one of my favorite browsers on the the 15.2 32 Bit version… Vivaldi 32 BIT it said it was for Linux-DEB 32 Bit… so I thought it would work… but I was wrong. Now I have installed the 64 Bit version of Linux-Deb and it doesn’t work either. I think I need a magic wand!

Question… how do you uninstall a program???

As much as I hate to, I will delete Vivaldi. I happen to love it. I use it strictly for watching online videos, movies & tv shows. It eliminates the need to use Chrome or Edge.


PS… Will try sending you both a private message now… if you don’t get it… send me one!

First, try using Synaptic: Installing packages using Synaptic Package Manager GUI

Using the terminal, you can uninstall using: sudo apt remove <package name>
If the package is a snap: sudo snap remove <package name>

1 Like


Your Reply empowered me to use the TERMINAL for the first time and it worked perfectly!

I saved your reply and the linked instructions on my computer… used them… and printed them.

Thanks to YOU… I’m not afraid of the Terminal anymore.



Seems like I am having trouble with caffeine too, but that might just be user error!

sudo xset s 0 0 still definitely works so I think I will stick to just running that on logon.