Display issues following the October 5 2023 upgrade

After installing the latest upgrade to Zorin OS 16, my Acer laptop (AMD A6 chip), my display goes nuts.

The home screen displays as per usual, but as soon as I enter my password and hit the Enter key, the screen fills with coloured and black and white lines. I am just guessing, but it looks like the menu bar at the bottom of the screen is scrolling by really really quickly.

Before descending into chaos, it did appear as if the software upgrader icon was trying to tell me there was something wrong. Unfortunately there is no way I can query that application before the screen goes nuts.

The easiest solution would be to simply reinstall the operating system, but unfortunately the memory stick that would allow me to do so is over 7 hours away. (I am currently communicating via my cell phone, which is not a whole lot of fun.)

Anyone out there have any suggestions?

Thank you in advance, JT.

Can you enter the Grub Menu from Boot.
Then select Advanced Options for Zorin

First thing I would try is booting into the previous Working Kernel as a test. If that works, then that should be all you need. You can then set that kernel as your default boot.

If not, From Advanced Options for Zorin, select Zorin on 5.15...(Recovery) and enter the Recovery menu.
Arrow key down to enable networking.
Once enabled, back up to the Recovery Menu and arrow key down to Root - drop to prompt

Bad the enter key...

sudo dpkg --configure -a

sudo apt update && sudo apt upgrade

Read the terminal output. Make sure no errors. If none - test a normal boot.

1 Like

Thank you for your prompt reply. And also, thank you for the instructions on how to get into the grub menu. I was successful getting into that menu as a result.

Nown how do I know which is the previous kernel? I have 4 choices, two of which are recovery mood.

The first choice is "Zorin, with Linux 5.15.0-86- generic" followed by the same line with (recovery mode) added.
The third choice reads as follows
"Zorin, with Linux 5.15.0-84- generic" followed by the recovery mode choice.

Where should I start? And if that works, how do I make sure that I reboot with the correct turn all?

Have I mentioned that I am a complete novice with Linux?

Cheers, JT.

Okay I see how to start with a new kernel.
My first question still remains how do I know which is the correct kernel to test?

Thx Aravsian, all your initial suggestions worked. The earlier kernel was the third one listed. From there, setting that kernel as the default boot (and not ignoring the re-boot a 2nd time suggested in the reset instructions) works well.

Any suggestions on what the initial problem was and how to avoid it? I have my desktop at home to update and I would hate to go through all this again, fun as it was the first time.

By the time I got back to this thread, two of your posts are no longer relevant.:wink:

You have now avoided it by locking in your kernel version.

As to exactly what the initial issue was - I do not have enough information.
Given that you are using AMD and the AMD graphics drivers are included in the kernel, it seems highly likely that the latest kernel contains either a regression or an AMD driver bug. This is uncommon that it is something this severe.

In the end it worked, so thanks once again. Hopefully it can help someone else. Cheers, JT

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.