Display issues

I'm using Zorin OS 15.3 with Liquorix on a GTX 1050Ti. Today I updated some things, including Liquorix from 15.1 to 16.1, and tried installing LoL with Wine. Apparently something got corrupted, since when I tried to start Minecraft it kept crashing and when I rebooted it it had many issues. Whenever I boot up Zorin, it boots with a horrible and really small resolution (must be something like 640x480 or 320x240) and all text is just squares. If I try booting via recovery mode, it doesn't boot at all or it has the same issue, same thing using just Linux and not Liquorix. I tried:

  • Uninstalling Wine
  • Uninstalling all display drivers
  • Installing Nvidia drivers from Software updater or via recovery mode
  • Switching to the Noveau driver

Absolutely nothing changes. I'm afraid the only solution may be to save all the files, wipe the partition clean, and reinstall everything from scratch, but I'd like not to do that since it'd take a lot of setting up and backing up and making sure I don't lose anything etc.
Is there any way to maybe install drivers from the live USB? Are there any other ways of solving this?
Please help

1 Like

If you hold the left shift key at boot (or for some, it is tapping the esc key) and enter Recovery Mode, can you boot from an older standard 5.0. Kernel?

Nevermind... I just processed this line.
What parameters have you set in grub?

sudo nano /etc/default/grub


I haven't changed any parameter, it's all default. I only have Linux 5.4 as kernel aside from Liquorix, should I try downgrading to 5.0?

No... I just couldn't remember exactly which kernel 15.3 is currently on. :expressionless:
Can you enter in terminal

sudo nano /etc/default/grub

Then change this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Try booting and relay the results. If that helps, or seems to be going in the right direction, it may help troubleshoot.

Nothing changes. Also, before the issue began, during boot the only messages I saw were "kvm is disabled in bios" or something similar, while now after the issue appeared it also shows a few lines regarding some services being started successfully (such as apache server), dunno if this could be useful.

What happens if you roll liquorix back to 15.1?

KVM is 'kernel based virtual machine'. Enabling it may initialize addititional hardware or graphical abilities.

I tried booting with the option for Liquorix 15.1, but the issues are still there. Enabling KVM also didn't do anything to help. Booting with Liquorix 15.1 actually gives some more info, it gives me a "version mismatch" error with the Nvidia drivers, but it goes by too fast to catch the numbers. Booting into recovery mode (on 15.1) and then resuming boot just hangs. I installed nvidia-driver-450 via apt-get.

Well, that may be a clue- what have you tried with Nvidia drivers? This was my thinking on nomodeset - to see if disabling Nvidia makes a difference.

I uninstalled everything and purged all nvidia files, then reinstalled nvidia-driver-450.

What about the 460 driver?

the 460 driver just gives dependency errors, it never successfully installed even well before any issues appeared.

update, I tried fixing the dependency issues with the 460 driver but it just doesn't work. I installed version 450. The version mismatch error has been fixed, since I uninstalled and reinstalled the driver multiple times already and purged everything I suspect there might be something not related to the display driver causing issues.

Here are the results from booting attempts
Linux 5.4: display issue
Linux 5.4 from recovery mode: text is all boxes
Liquorix 15.1: display issue
Liquorix 15.1 from recovery mode: does not boot (blinking pointer)
Liquorix 16.1: display issue
Liquorix 16.1 from recovery mode: does not boot (blinking pointer)
(Display issue means very small resolution and all text is boxes)

What xserver are you using?
Have you tried reinstalling xorg-xserver?

sudo apt install --reinstall xorg

I tried and nothing changed, I'm using the default xserver. One of the things that could've caused issues, that is installing LoL via Wine, showed an error message about S3TC not being installed. Maybe it could have something to do with the issue?

nvidia-smi gives error "Failed to initialize NVML: Driver/library version mismatch", but I've purged everything every time I uninstall and reinstall. I'm gonna try and install an older version (nvidia-driver-390). Also, whenever I reinstall, it tells me "Need to get 0B/[total size] of archives", and I don't know how to purge that, maybe the issue lies there.

Edit: even with nvidia-driver-390 it gives me the version mismatch error.

It could. I never use WINE and am functionally useless about giving advice about it... I have no idea what software LoL is... Lord of Love? Lyrics of Llamas?

League of Legends. I uninstalled WINE but the issue is still there. I tried some guides to get rid of the version mismatch error but they don't work

Uninstalling WINE may not do the trick, as residual configuration files or pieces may still create the issue.
You would need to purge all of that to be sure.
I feel your pain, but am currently at a loss. Will keep searching- but I hope you have back ups ready considering your own attempts have been fruitless so far.

You did not log in on Wayland by accident at some point, did you?

I didn't. The issue just involves the graphics driver, so the files are still there and I can access them with a live USB or from Windows using DiskInternal's Linux reader. Reinstalling would be annoying however, as I'd have to set up and reinstall everything again. It's not really about file loss, it's about time loss. I'll try and look around and see if there are any Wine files or packages that I can remove.

I understand what you mean. In addition to removing configs from wine: Have you tried installing, then booting from, a newer kernel? Not Liquorix, but even an unsigned 5.8 or above kernel- to see if it helps?