Display running at lower resolution

I have a Zorin 16 system with Samsung 27" monitor and an NVIDIA GM206 [GeForce GTx960].
When I first installed Zorin about a month ago, it gave me a 1920 x1080 display by default.
Since then I've reinstalled and now I have a 1024x768 display and in the system settings I no longer have an option for 1920x1080.

I followed along with this post Screen resolution support and am putting the output from the xrandr commands here. Sorry for the possible overload:

christian@christian-MS-7A15 ~> xrandr -s 1920x1080
Size 1920x1080 not found in available modes

christian@christian-MS-7A15 ~ [1]> xrandr --newmode "1920x1080_76.00"
xrandr: failed to parse '1920x1080_76.00' as a mode specification
Try 'xrandr --help' for more information.

christian@christian-MS-7A15 ~ [1]> xrandr --addmode HDMI1 "1920x1080_76.00"
xrandr: Failed to get size of gamma for output default
xrandr: cannot find output "HDMI1"

I deleted the file ~/.config/monitors.xml like Storm suggested, and tried again.

christian@christian-MS-7A15 ~> xrandr --newmode "1920x1080_76.00"
xrandr: failed to parse '1920x1080_76.00' as a mode specification

christian@christian-MS-7A15 ~ [1]> cvt 1920 1080 76

1920x1080 75.94 Hz (CVT) hsync: 85.89 kHz; pclk: 224.00 MHz

Modeline "1920x1080_76.00" 224.00 1920 2064 2264 2608 1080 1083 1088 1131 -hsy
nc +vsync

christian@christian-MS-7A15 ~>
xrandr --newmode "1920x1080_76.00" 224.00 1920 2064 2264 2608 1080 1083 1088 1
131 -hsync +vsync
xrandr: Failed to get size of gamma for output default

Here in the post I saw a link to askubuntu at:

and went there but I didn't understand most of what was said.

If I have to live with this lower resolution I guess I can but if anyone can help me figure this out I would much appreciate it.



What is your Graphics card make?

It's NVIDIA GM206 [GeForce GTx960].

Can you open Software & Updates and then the Additional Drivers tab and relay what Driver is selected?

In terminal, run

sudo nano /etc/default/grub

And relay what is on this line:
Does it say "nomodeset"?

Software & Updates doesn't like me ("Conversation with su failed" - but that's another thing), so I clicked on 'Ignore' to get in.

NVIDIA Corporation: GM206 [GeForce GTx960]
This device is using a manually installed driver.

from my /etc/default/grub

GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

It does not say "nomodeset".


Let's stop for a moment and focus on this...
Can you clarify these details? Did you personally install Zorin OS? Are you using a User Account or the Admin account? Do you have access to Root with a Root password?

Yes, I personally installed Zorin OS and I'm using a User Account (Christian). When I need greater privileges I use "sudo" and not "su" because sudo accepts my password and su does not.

I'm a little unclear on your last question. I don't have another password for Root AFAIK. I just use sudo when I need to.

Can you please detail what action you perform that produces "conversation with su failed"?

Sure. When I tried to open Software and Updates I get "Conversation with su failed".
When I type su on the command line, and then give my password, I get "Authentication failure".

In Zorin OS (Based on Ubuntu) we only use sudo not su.
Sudo is a package installed on the distribution that handles authentication and communication.
When you use the command sudo, you are calling on that Sudo Software to run. So, using su will not work on Zorin OS. It will work on other distributions that use that package.
How are you opening Software & Updates? Clicking it from the App Menu?

I am sure you can see where I am going with this... IF something more is wrong with your installation - it may also explain the resolution issue.

I see. We don't use su. I didn't know that, thank you!

To open Software and Updates, I click on KDE menu, go to Applications, then Settings and click on Software and Updates. Then it asks for my password and then gives me the Conversation with su failed message.

Actually, I didn't know where you were going with this. That's scary. It's possible though, since the first time I installed Zorin, the resolution was fine. Thing is, I don't think I did anything different this second time I installed.

You installed the KDE Desktop on Zorin OS?

Yes I did.

KDE uses the SDDM Display Manager, if I recall correctly.

Also, Some Gnome Software will not work on the KDE Plasma desktop (KDE is Qt built rather than Gnomes GTK build).

So that would also explain the trouble you are having.
Did the lower display resolution appear after installing KDE?

Actually, no. The low resolution was as soon as I installed Zorin OS the second time. Before I switched to KDE.

The first install was fine, but not the second install? have you tested using the LiveUSB to see if it has the Normal Resolution?

That's right. First install was fine, not the second.
That's a good idea with the LiveUSB. I will do that now! brb

1 Like

OK. The LiveUSB has the proper resolution along with a choice of about twelve other lower resolutions. It looks great and was depressing to come back.
So it looks like you are right. I've somehow messed up my install the second time.
I guess I need to reinstall. Do you have any idea where I might have gone wrong?
Aravisian, thank you very much for all of your time and patience with me. I'm sure you have better things to do.



Sadly... If I did... I would suggest that instead of a reinstall.
When it comes to troubleshooting something that needs a driver, that is one thing.
But a Corruption that occurs during installation is much harder to pinpoint. Sometimes you get lucky, other times you spend a week on it.
If it was me... I would go ahead and re-install just to ensure a good, clean fresh start. Because if that One Thing you Know About corrupted... What else was that you do not yet know about? You might solve the immediate problem only to find a different one elsewhere later.

Install corruption can occur to a bad sector or to packet loss on Download or due to a file remaining on the drive instead of being replaced. As your LiveUSB works, we will assume the download was fine.
I would suggest Wiping the drive before reinstalling Zorin OS.

1 Like

Well, I have my beloved 1920x1080 display back after following your advice and reinstalling Zorin OS.
Actually I reinstalled twice.
The first time I still had the 1020x768 (or whatever) and thought I would give it one more try. I should have waited a little while, as I found out later.
The second time I again had the lower resolution. I considered giving Linux Mint a try hanging my head and went to their website to investigate.
While I was reading about Mint, a pop-up box came up and told me there were additional drivers to download. Among these were some NVidia drivers. I randomly chose one of them and after restarting, I had my proper display back.
I'm not sure if any of this is useful, but thought I should summarize my adventures in case anyone is keeping tabs.
Aravisian, thank you again!