Docking station Kensington SD3500 on Samsung R519 with Zorin OS 16

Hi everyone,

I would like to use Kensington SD3500 Docking Station - Display Port & HDMI on my Samsung R519 laptop .I have gone to the website of Kensington and downloaded the display driver for Linux Ubuntu but its not working and displaying on an hdmi tv that I have.
The driver that I have is 'displaylink-driver-5.4.0-55.153.run '.

This is my 1st time to use Zorin OS 16 and I am using the core version so if more information is required please let me know.
I am a windows user trying to take the leap to Linux.
(The SD3500 docking station works perfectly on my pc computer which is running windows 8.1)
Details about my laptop are as below.

Blockquote ```
Machine: Type: Laptop System: SAMSUNG product: R519/R719 v: N/A serial: Chassis:
type: 10 serial:
Mobo: SAMSUNG model: R519/R719 serial: BIOS: Phoenix v: 08CI.M055.20100210.JIP
date: 02/10/2010
Battery: ID-1: BAT1 charge: 27.5 Wh condition: 27.8/48.8 Wh (57%) volts: 12.5/11.1
model: SAMSUNG Electronics serial: N/A status: Charging
Device-1: hidpp_battery_0 model: Logitech M705 serial: charge: 10%
status: Discharging
CPU: Topology: Dual Core model: Celeron T3100 bits: 64 type: MCP arch: Penryn rev: A
L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 7581
Speed: 1895 MHz min/max: N/A Core speeds (MHz): 1: 1895 2: 1895
Graphics: Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Samsung Co driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:2a42
Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express x86/MMX/SSE2 v: 2.1 Mesa 19.0.8
direct render: Yes

Thanks and hopefully I can have this solved.

1 Like

Is this the Kensington?
https://www.kensington.com/p/products/device-docking-connectivity-products/laptop-docks-usb-accessories/sd3500v-5gbps-usb-3.0-dual-2k-docking-station-hdmidvi-ivga-windows-1/

I can't find any drivers for Linux on the website. I also couldn't find anyone using it. Maybe @Aravisian can help you.

1 Like

I looked at the specification on the page @Kedric posted a link:

  • Compatibility

Windows 7 or above, macOS 10.14 or above

No Linux in sight - does not look very promising.

1 Like

Even we got it working, a lot of the feature's wouldn't work because there is proprietary software.

1 Like

Exactly.
Linux users should be aware, there are many hardware in market which would never work in Linux because of the propitiatory nature of drivers/firmware.

2 Likes

Feel kinda bad for @cn90, currently I have no idea to solve this problem because of the lack of information. You can try contacting kensington themselves, I don't want to give my email to Kensington, my dumb friends keep signing me up for Pocket and N*** stuff with my Gmail, it's annoying.

1 Like

The problem with the display link driver is that Gnome's GDM3 display manager interferes with the driver.
The Display Link driver will work and run on XFCE with LightDM.

I would suspect that if you are a Windows user that is new to using Linux, XFCE would be easier to learn and manage than Gnome for you, as well. More works 'out of the box' with XFCE with less troubleshooting. More settings are openly visible.
If you like, you can install XFCE4 and LightDM on Zorin 16 Core. We can walk through that process.
Once done, we can reinstall the driver and use modprobe to enable it.

1 Like

Thanks for the reply guys .

I got the drivers from

Drivers

I choose the Ubuntu 20.04
Release: 5.4 | Apr 6, 2021 driver as the 6th Sept wasn't there , but even if I use it now would there be a difference ?
I have contacted Kensington regarding this but they say the driver only works for Ubuntu and are not willing to help further.

I can borrow a Kensington SD3650 universal dock or a Lenovo Thinkpad Hybrid usb C to usb A docking station if the displaylink drivers will work on Zorin OS.

Any ideas ?

Yes I can give it a try and see if it works , I am ready to learn if you tell me what I have to do to install XFCE with LightDM .

What is LightDM ,btw ?

GDM and LightDM are both Display Managers. Another is SDDM. You can see the common trend, here. :wink:

If you would like to install xfce on Zorin OS 16 Core, open a terminal and enter in:

sudo apt install xfce4 lightdm numlockx xfce4-whiskermenu-plugin xfce4-zorinmenulite-plugin

I threw in the packages for the Zorin App Menu and Whisker Menu (app Menu) above, you can remove them from the command if you want. I prefer whiskermenu as it is very functional and configurable.

Installing LightDM will take you through a series of prompts in the terminal. Follow the prompts fearlessly and select LightDm as your default.

Ok I will install the LightDM.

A few more questions :
In the install instructions in section F of the link [Release notes] where should I have the run file ?
Right now I have the run file on the desktop. but keep getting an error of " sudo: ./displaylink-driver-5.4.1-55.174.run: command not found "
I have installed dkms as per the instructions in section F.

(https://www.synaptics.com/sites/default/files/release_notes/2021-09/DisplayLink%20USB%20Graphics%20Software%20for%20Ubuntu5.4.1-Release%20Notes.txt)

sudo: ./displaylink-driver-5.4.1-55.174.run: command not found

To install the release, from a terminal window, with root permissions use the command:

sudo ./displaylink-driver-XXXX.run

Where displaylink-driver-XXXX.run is the name of the extracted DisplayLink driver.

The dkms framework is required for installation of DisplayLink. This can be installed with the command: sudo apt-get install dkms

More detailed information on installation can be found at http://support.displaylink.com/knowledgebase/articles/615714#ubuntu

Running a command in terminal runs it from the location the terminal is opened in. When you open a terminal, it opens by default to Home Directory. You can use the CD command to change directory to a different directory in which you need to do work.

cd ~/Desktop

Then run the command to install.

Its asked me to install so am now going to restart the laptop and see if this has worked.
Please let me know if I have included any private info that shouldn't be there in the paste file.

Blockquote Detected running Xorg session and connected docking station
Please disconnect the dock before continuing
Installation terminated.
max@max-R519:~/Desktop$ sudo ./displaylink-driver-5.4.1-55.174.run
Verifying archive integrity... 100% All good.
Uncompressing DisplayLink Linux Driver 5.4.1-55.174 100%
DisplayLink Linux Software 5.4.1-55.174 install script called:
Distribution discovered: Zorin OS 16

Installing

[ Installing EVDI ]
[[ Installing EVDI DKMS module ]]

Creating symlink /var/lib/dkms/evdi/1.9.1/source ->
/usr/src/evdi-1.9.1

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area...
make -j2 KERNELRELEASE=5.11.0-27-generic all INCLUDEDIR=/lib/modules/5.11.0-27-generic/build/include KVERSION=5.11.0-27-generic DKMS_BUILD=1...........
cleaning build area...

DKMS: build completed.

evdi.ko:
Running module version sanity check.

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/5.11.0-27-generic/kernel/drivers/gpu/drm/evdi/

depmod.........

DKMS: install completed.
[[ Installing module configuration files ]]
[[ Installing EVDI library ]]
cc -I../module -std=gnu99 -fPIC -D_FILE_OFFSET_BITS=64 -c -o evdi_lib.o evdi_lib.c
cc evdi_lib.o -shared -Wl,-soname,libevdi.so.0 -o libevdi.so.1.9.1 -lc -lgcc
cp libevdi.so.1.9.1 libevdi.so
[ Installing x64-ubuntu-1604/DisplayLinkManager ]
[ Installing libraries ]
[ Installing firmware packages ]
[ Installing licence file ]
[ Adding udev rule for DisplayLink DL-3xxx/4xxx/5xxx/6xxx devices ]
[ Adding upstart and powermanager sctripts ]

Please read the FAQ
http://support.displaylink.com/knowledgebase/topics/103927-troubleshooting-ubuntu

Installation complete!

Please reboot your computer if intending to use Xorg.
Xorg is running. Do you want to reboot now? (Y/n)

Hit y,
then test.

If it is not working, you may need the Linux built driver:

modprobe evdi

1 Like

YES !!!!!!!
YES !!!!!!
That did it !!! Thanks for your help its working now and I am using my monitor as I am typing this .
Thank you everyone for your suggestions .

Hitting Y did the job and I didn't need the Linux build driver !!!

3 Likes

Good. Now, you will notice a countdown timer on the panel stating XX time until Computer destruction. Just ignore that.
It's fine.
It's totally fine....

2 Likes

Youtube seems a bit laggy on firefox , if I install Chrome will that sort it out or is it cos I have only 2GB of ram and its struggling ?

2 gigs of RAM is a little low. I would think that Chrome would be more resource intensive, not less.
What is your Video Refresh Rate?

Video Refresh Rate ?
where will I find that ? on youtube or on my OS ?

On your OS. Are you using XFCE or The default D.E. you started with (Gnome)?