Document Viewer (Evince) White Select Colour impossible to see

Hi the Dark Gray Theme causes text selection colour to be white which makes it unreadable against white background. This makes it impossible to see what you selected in Document Viewer (evince). When I turn nightmode on, I am able to see the selected colour to be white.

1 Like

I moved this to Feedback forum in order to help it be more visible to @AZorin and @zorink.
In this way, they can see that a modification needs to be made to the theme.

In the meantime, can you please post a screenshot? Perhaps I can help you create a workaround to keep things visible.

When I turn Night Mode feature it makes the document background black so the select highlights appears white. With this feature off the select highlight is still white but since the document background is white, I can't see it at all.

1 Like

1 Like

I am very glad you asked about this... because in following up, I realized that several of my own themes had this same issue (I don't normally use Evince). Sorry, to take so long- I was correcting each of them before I forget to and making a note to update each theme for uploading.

So... a workaround you can use:
Create a file named gtk.css and place it into your ~/.config/gtk-3.0/ directory
Paste into it: @define-color theme_selected_bg_color #00c3ff;
You can change that color to any color you want. Just ensure that the text color still shows.
Log out and in again to view the change OR just use the theme changer to change the theme to something else, then back again.

Keep an eye on your coming updates: When ZorinGroup releases a theme update, you may want to comment out that line in your ~/.config/gtk-3.0/gtk.css file.

It doesn't seem to work.

That is odd... It works on mine; I tested it prior to posting the suggestion.

The other option would be to elevate your file manager to root

sudo -i

nautilus

Then navigate to /usr/share/themes/ And click into the Zorin Themes You Are Using. The way Zorin Appearance is set up, it will be the Light theme or dark theme, combined with the accent color. "Zorin-blue-dark" for example.
Navigate to gtk-3.0/gtk.css and scrollbar that puppy all the way to the bottom OR hit ctl+f for find and search for @define-color theme_selected_bg_color

Replace the color - For example: @define-color theme_selected_bg_color #bde6fb; with a more visible color. Save and exit.
Do this for the day mode (light theme) and night mode (dark theme).

Tried your suggestions and oddly it still doesn't work.

I am not sure what is going on with this one... I have tried using multiple different colors and it changes each time:
test

The only thing I can suggest is re-tracing your steps or waiting for ZorinGroup to update the themes.

I tried again but it still didn't work so I'll wait for ZorinGroup to update the themes. Thanks for taking the time to help!

1 Like