Dual Boot - Keyboard and Mouse NOT Working after switching OS

Hello. I have a problem when switching back to another system my keyboard and mouse not working. If i restart PC again or shutdown then it working again. Any solution? Some problems with port USB, Fast Boot in bios or using usb 3.0 then change to usb 2.0 could fix that. This is what i find on uncle google. Maybe someone have a near the same problem and how fix that.

Often, keyboard and mouse work best when plugged into 2.0 port, not 3.0. A USB hub, however useful, is also best avoided (due to them being cheaply made, really, not due to it being a hub by nature... A Good Quality hub should be no problem.)
You may need to install

sudo apt install xserver-xorg-input-all

So. I have in my motherboard a red port usb also blue ports usb. It doesn't matter where I connect them. They are not working. This must be something in Bios or somewhere else settings to configure that. When shutdown a computer from zorin linux then a keyboard and mouse not working if back to another operating system but if restart they start working.
"I got it fixed. The problem was related to USB 3.0.

Solution was to change Intel xHCI Mode from "Smart Auto" to "Auto" (or just disable it) under Advanced - USB Configuration. So it will not use USB 3.0 during the boot.

Note: Also make sure that Legacy USB support it set to Auto or Enabled."
Find something that but if I disabled this then they will full disabled or they change for 2.0?

1 Like

xserver-xorg-input-all is already the newest version (1:7.7+19ubuntu14).
xserver-xorg-input-all zaznaczony jako zainstalowany ręcznie.(installed manually)

1 Like

It is my understanding that USB3 ports are usually blue.

I don't have on my motherboard black usb what they are 2.0. I reading somewhere usb 3.0 are friendly with lower all version port usb. So your solution is using a hub usb port 2.0? and then connect to the motherboard?

Ok. Then my question how linux working on another computers and motherboard what have only 3.1 and 3.0 port. Everyone need to buying a hub to correct working a operating system when switch to another? It is some joke?

My suggestion is port 2.0 for keyboard & mouse. On my own Acer computer, keyboard works better in a 2.0 port.
A Hub may cause problems. Many Tower PC's offer lots of ports at the back, allowing to get away from hubs on peripherals and freeing hubs for things like USB sticks, phone chargers and the like.

I tried hub and connected both mouse and a keyboard also not help.
My motherboard is MSI Z97A Gaming 7
For me this is annoying. It must be some solution.

For what it is worth I have a 4-way USB3 Hub on my Win laptop for mouse, printer and wifi dongle. I would not add anything else to that, especially anything like a phone or external drive that could be power hungry. Luckily I have another port for that.
My Zorin laptop is antique so only has USB2 ports, but does have luxury of 4 of them built in. Before the days of wafer thin notebooks with minimal external interfaces. Never had problems with USB mouse or other USB devices on those USB2 ports.

1 Like


Red ones are USB 2.0.

1 Like

You learn something new every day on here. USB2 either Red or Black.
Bit like old insulation colour coding for mains power live wire. UK was Red (now brown), USA Black (remembered as "black death").

1 Like

Then this is not working. The red ports.

Just for your reference, here's my BIOS configuration:

Legacy USB support [Enabled]
EHCI Hands-off [Disabled]

I do not see XHCI Hands-off in my BIOS.

front i have connected external hard disk ssd linux and a microphone.
Ok then if the ports 2.0 usb not working. I tried all ports then where is the problem?

You mean you have a hardware issue for those ports?
Did you test it by connecting a USB stick to those ports?

Ok maybe in shortly how it doesn't works. Example first i started operative system Windows 7 then I restart using a keyboard F12 to choose a Linux Zorin 16 Pro still all mouse and keyboard are working. When I restart from Zorin to back a Windows 7 then my a keyboard and mouse not working and i tried red and blue ports usb in this motherboard also tried with hub what @Aravisian wrote.

When restart from Linux to a Windows I tried unplug and plug again to usb ports and also not working. I need full restart. Switch power off not working in this situation.

Is this issue fixed or not fixed?

Also- I pointed out that a hub may cause issues in which case to not use a hub. This does not apply to all, just to those affected by their hub.

1 Like