Dual booting Zorin 16.2 with Windows 11 (py Error message)

Hello,

I am writing because I am having trouble successfully installing Zorin OS v16.2 on a machine with Windows 11 latest installed. I have installed many Linux flavors over the years but have not run into the error I have been receiving recently which states the following during the installation:

GLib.source_remove(self.rows_changed_id) /usr/lib/ubiquity/ubiquity/frontend/gtk_components/nmwidgets.py:17: Warning: Source ID 954978 was not found when attempting to remove it
GLib.source_remove(self.timeout_id) /usr/lib/ubiquity/ubiquity/frontend/gtk_components/nmwidgets.py:133: Warning: Source ID 955100 was not found when attempting to remove it

Below are the following items I have already tried for troubleshooting steps:
-Secure boot is disabled
-Fast boot is disabled
-I have tried partitioning the win 11 drive as an exFat (I will probably try to partition as another format just to test what happens)
-I changed the power options so that the machine shuts down instead of hibernating or sleeping.
-Update everything including the BIOS
-I have tried different sequences of restarting the machine.

*I cannot always see the windows drive when i boot into the Zorin (NVIDIA) installation. Usually this only sees the drive itself which has the Zorin installer on it.

The Specifications for my machine are below:
Asus Zenbook (Model: UX392F)
Windows 11 Pro (22H2)(x64)
OS BUILD: 22621.1848
16GB RAM
I7-8565U CPU @ 1.8GHz x 8

The SSD Specs are below:
SATA MODE SELECTION: [AHCI]
SSD 1000GB
WD Blue SA510 M.2 2280

Please, let me know if you need anything else from me!

This should have no bearing on Zorin OS - Are you formatting the Zorin partition as ext4?
Are you using the manual "Something else" option or the "Install Alongside Windows" option?

@Aravisian
So far I have used Rufus to format the Zorin image as both a MBR & GPT w/ the recommended ISO. When you mentioned formatting as ext4 are you talking about formatting the 1TB drive itself? I tried formatting a part of my drive as exFat & as NFTS just to see if there would be a difference.

I tried to use the "Install Alongside Windows" option and that is when I get the error. The something else option does not appear to me. In fact it is hard for me to figure out why 3/4 times I cannot get either option (Install alongside Windows" or the "Something Else" option.

Fully defragment Windows OS.

Once that is done, in your partition manager, select a reasonable size partition for Zorin OS. The partition (not the entire drive) can be formatted to ext4.
IF Windows occupies the entire drive;
You can use the Windows Partition Manager to shrink Windows partition and create free space. Then select that free space to create a new partition for Zorin OS and format it to ext4.

Boot the Live USB of Zorin OS and proceed to try to install...

2 Likes

Is there a way to format the disk as ext4 from within Windows?

If not, I tried everything mentioned above including the following two articles below, and I have tried using the "Install alongside Windows" as well as "something else" and as soon as I get past the screen where I chose the drives to partition and install on I receive an error that the drive is no longer available.

https://www.xda-developers.com/dual-boot-windows-11-linux/

Let me know if there is anything else to try!

In your BIOS settings, is the drive set as RAID or AHCI?

It is currently set to AHCI. The only other option is "Intel RST Premium With Intel Optane System Acceleration"

1 Like

Given your link - Is your drive encrypted (Bitlocker?)

No, thankfully I have not encrypted it. I just used part of the article for reference.

You may need to use Gparted on the LiveUSB trial of Zorin OS to format your drive.
A screenshot may help us to see if there is something unusual about the drive.

This article might help?:

You can use Partition & Install for a guide to configure the drives and install Zorin.

Did you put the nvme drives in yourself? Open the computer and make sure they are seated properly (ground yourself before touching anything in the computer). A firm push (not real hard, a little harder than pushing a button) should ensure they are seated properly.

nope, it doesn't.

This?

https://help.ubuntu.com/rst/

I think your iso is corrupt. The error has to do with nmwidget.py for the ubiquity installer. Since a library is missing from the installer, it fails.

Compare the md5 or Sha1 checksum against the values listed on the official download page for zorin. If they don't match, redownload the iso.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.