Dual Monitors Not Working on 4070 Ti

Hi everyone,

I recently installed Zorin OS alongside my Windows 11 OS on my gaming desktop.

When I first ran the Zorin USB installer, I chose the "newer NVIDIA graphics" option to run Zorin OS in a live environment and both of my monitors were working in the live environment. I have 1 monitor hooked up over DisplayPort and another to HDMI on the Nvidia RTX 4070 Ti GPU.

After installing Zorin, I booted into the OS and came to find that the DisplayPort monitor was working but the HDMI monitor is not. I checked into the drivers under Software > "hamburger menu" > Software & Updates > Additional Drivers and tried all of the available drivers here with a restart, but none seem to be working. I followed the steps on this guide from this forum to reinstall NVIDIA drivers [How to] Reinstall NVIDIA Graphics Driver but this didn't correct the issue either.

I'm at a loss what this could be. Can anyone help me?

Thank you!

EDIT: To add more information, here are the current list of drivers available under Software > "hamburger menu > Software & Updates > Additional Drivers in case this helps provide any additional information to my post

I have tried all of these drivers and performed a reboot after enabling each. I have also gone to Nvidia's website and manually downloaded their driver to try as well. No luck on any of these options, including Nvidia's website's driver for Linux.

I once had a very similar issue.
First, check the On-board monitor settings for its output.

What I ended doing was unplugging both monitors, switching their positions in the desk. Then hooking up the cables - what was HDMI the first time became the DP and the DP Became the HDMI.
Then it worked.

Thank you for the tip!!

I tried it but unfortunately that didn't seem to work either. When removing both and replugging them, Zorin actually no longer detected a monitor at all. I tried plugging in just the HDMI then the DP but no dice, then tried the DP first and then HDMI and still nothing. I rebooted but this time POST started on my HDMI when it usually starts on the DP then allowed me to log into Zorin but this time all that displayed was on the HDMI monitor, nothing on the DP monitor. Not even when I removed cables and replugged the cables in any order. HDMI still stayed connected unlike the last time, though.

I did one more reboot and now it's back to how it was before, where computer POSTs to DP and Zorin stays on the DP monitor and no signal is detected on the HDMI monitor.

When you say, "check the on-board monitor settings for its output", can you describe a little more what you mean here? I've checked Zorin's Display settings under Settings, but it only lists one monitor here on both times.

The monitor itself. Most monitors have a settings menu built in.
On the two I am using (One HDMI, one DP), there is a button on the bottom right of the monitor. I can set Centering, Brightness, Input source, Output source...

On Zorin, you can check your drivers.
In terminal, run

sudo apt update && sudo apt upgrade

sudo ubuntu-drivers install

From the App menu, open Software & Updates and move to the Additional Drivers tab.
It will search for drivers for a moment...
Then look to see which driver you are currently using. Please relay that info here.

Ah understood, thanks!

Yes, I checked the monitor's settings menu on it, and I can confirm that it is set to HDMI. Only other option is Analog for VGA, which is not plugged into anything. When checking the settings for this, the monitor is now cycling through HDMI and Analog trying to find a source, which it doesn't normally do.

I ran those commands but it doesn't look like there have been any new updates. Here is what I am seeing under Additional Drivers

I have tried all of these drivers as well as the driver provided from Nvidia's website for this GPU specifically for Linux. After enabling each option from the Additional Drivers page as well as Nvidia's driver, I performed a reboot of the computer but didn't see a change.

Can you run

sudo prime-select nvidia

Reboot, test...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.