Elan touchpad is not recognised and not working

My laptop is lenovo 100e 2nd Generation 82GJ (windows preinstalled). I installed Zorin OS Lite 16.3. Elan Touch pad is not recognized in Zorin OS Lite. But in Bios settings before booting the touchpad is working.
Does anyone know how to make it work

I tried some solutions suggested on this forum and internet. But none of them provide any solution

As you can see here;

Elantech has a pretty long history of been a bit more figgity with GnuLinux than other manufacturers.

First thing every user should do after installing Zorin OS is run

sudo apt update && sudo apt upgrade

Can you please relay the terminal output of

xinput list

This is to check if Elan is listed.
If it is not, you might try:

sudo apt install xserver-xorg-input-synaptics

to see if the Synaptics Drivers recognize the device.
If still no good, you might add the Grub parameter psmouse.elantech_smbus=0

(Do not forget to run sudo update-grub after saving the file).

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.