Error installing drivers nvidia 390 on Zorin OS 17

Hey guys, I'm trying to install the Nvidia drivers from the software and updates provided by Zorin OS or Ubuntu I don't know, but from here these generates an error, I try install with the drivers downloaded from the official page and I receive the same error, why I need to change the Nvidia drivers? Because the "Nouveau" drivers produce a little screen pauses or freezes, the videos reproduce with fine but any times produces freezes too (isn't my net), and with the Nvidia drivers in other distro's I don't have problems, obviously I know that is for the Kernel, but I ask if you have any solution for this issue, I tried change the kernel version to 5.8, but I continue receiving the same error:'c

What error is being produced?

Which graphics card are you using?

sudo lshw -C video


sudo lshw -C video
Description: VGA compatible controller
Product: GF106GL [Quadro 2000]
manufacturer: NVIDIA Corporation
physical id: 0
Bus information: pci@0000:01:00.0
logical name: /dev/fb0
version: a1
width: 64 bits
clock: 33MHz
capacity: pm msi pciexpress vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=nouveau latency=0 resolution=1680.1050
resources: irq:30 memory:f6000000-f7ffffff memory:d0000000-d7ffffff memory:d8000000-dbffffff ioport:e000(size=128) memory:c0000-dffff

my uname -a
uname -a
Linux Z210 6.5.0-21-generic #21~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Fri Feb 9 13:32:52 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

In terminal, have you run:

sudo apt install nvidia-driver-390

If it installs with no errors, reboot and test. If any errors relay them here in this thread.

ok, I will try this solution, but wait me for 2 days, I'm working right now

Hi. I am facing the exact same problem. After using

sudo apt install nvidia-drive-390

i get this error

Fehler traten auf beim Bearbeiten von:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also tried sudo apt install -f but got the same error codes

Any ideas?



sudo apt --fix-broken install

Next, check your sources and Server location; Try switching to Main Server under "Download from:" in Software & Updates
Then in terminal, run

sudo apt update && sudo apt full-upgrade

sudo apt install nvidia-driver-390

I tried to fix it but the only thing I got was that I stopped recognizing the drivers of "nouveau" and I kept the screen in the resolution 800x600

I receive the same error

Let's add the Kelebek repo, then:

sudo add-apt-repository ppa:kelebek333/nvidia-legacy

sudo apt update && sudo apt install nvidia-driver-390

I had to reinstall zorin os, but with the command "sudo apt install nvidia-driver-390" and without using "Software & Updates" at all, ie recently installed the Zorin OS, it worked perfect, in the 2 times that I tried it had used first "Software & Updates"
thank you my friend for your time <3

I had to install with the ppa you gave, all the apps were blank

nope, I receive the same problem with any apps, don't open this

@CarlosRivera4726 Sorry i did not understand. Did you reinstall Zorin or used the PPA? I Upgraded from 16.3 so i cant reinstall

1 Like

Tried but still the same error :frowning:

If you click Package Details on the lower right hand side above the package list, you can see that the package is in the repository for Nvidia-Driver-390.
However, I also see that Kelebek named the packages differently than how they are named on the Ubuntu drivers team's repo.

Can you please try:

sudo apt install nvidia-graphics-drivers-390

E: Paket nvidia-graphics-drivers-390 kann nicht gefunden werden.

not found

Did you remember to run sudo apt update after adding the new repository?

Here is the .deb file from that repository:

Yes I did the apt update. Installing manually now. ty

1 Like

Installing the .deb file worked. I still dont get why it did not work over the console... But thank you alot for your support!

1 Like