Error: NVram is locked (Zorin not found in efibootmgr)

This forum has been providing help from the moment you first posted.

Any of us can understand "Bleeping Computer" frustrations. It induces rage like being cut off on the highway.
And in just the same way, understanding the primal base of rage so you control it instead of it controlling you is how we turn problems into solutions. It is how we safely protect our investments and ourselves.

Is your drive set to AHCI or to RAID? You can find these settings in your BIOS Settings.

You may have overlapping partitions if the primary partition was placed within the extended partition.
If you can boot the LiveUSB of Zorin OS, select Try Zorin, then run Gparted and show a screenshot of your partitions.

MBR (Legacy) also operates differently than EFI. MBR only allows up to four bootable partitions. We need to look at what you have on that disk.

3 Likes

Looked right over that, good catch for sure ..

@BLAlley Are you able to take pictures of your BIOS settings with your phone or other device and upload them? As many of the screens / settings as you can get.. We're all kind of flying blind here, heh..

I set the boot device as the USB stick to install. When done it (once) said to remove the USB and press Enter to restart. It says nothing about resetting the boot drive even though I tried it both ways, letting it default to the second since the USB was removed, and changing it to boot from the HDD.
I even tried resetting the CMOS since it keeps giving the NVRAM locked error.

If there is a partition problem it was caused by Zorin since it's a brand new drive that has never had anything on it, including Windows.

Then this likely eliminates the possibility of a partition error. Can you post the screenshot requested?


I have changed the thread title to reflect the nature of the problem you are trying to solve.

3 Likes

In which way - through the 'reset all settings' option in BIOS? That could just reset all the settings to defaults, keeping the NVRam status..

Most desktops, definitely the older ones, have a CMOS jumper.. have you tried resetting with this jumper instead? With the machine off: move the jumper to the 'reset' position, power the machine on for a few seconds - it may even beep at you, no worries - power off, then replace the jumper back to the nominal position and proceed to test booting again.. but, just one way to clear.. This may not work, it may work - only one way to know :+1:

2 Likes

I did both. Reset to default settings and then used the jumper.

Alright - I do see RAID settings. Try changing that to AHCI..

Don't normally see this one a lot, but when it does come up, I usually tend to forget about that one - definite good catch @Aravisian

2 Likes

Change it and install Zorin again?

Just change to AHCI and reboot - should go right through..

JFC it worked. Now I'm P.O.d that no one else I've seen is suggesting this as a solution nor are the Zorin devs including it in the installation instructions or at least in the troubleshooting section.
Regardless, I thank you for the extended attempts to help including the final solution and Aravisian for the initial catch.
I'll go play around with it just to make sure it's working.

1 Like

Definitely good to hear; don't worry about it man! One little setting has set me back before, head scratching and all lol.. Stuff happens! Just brush it off and enjoy that Zorin install :sunglasses:

(edit) There have been a lot asking that before, actually - about RAID and why it won't work but, Linux OOB just isn't set up like Windows to be able to recognize the option and install accordingly / set disk management options and such for RAID use. This can be done with Linux / Ubuntu / Zorin / insert distro name here, but just requires a few extra steps to get going - and, not extensively needed if you aren't going to be striping, cascading, or mirroring any disks - especially with just one disk.

But, sometimes it takes a few more steps to get to the answer - no worries though, you're all set and can now enjoy that hard work :+1:

2 Likes

Troubleshooting can involve a large number of suggestions and attempts. If we list everything that we could try on various systems and machines, it would get so long that most people would be daunted by the mass of it. They would be left wondering which to try first, which to prioritize, which apply to them and their machines and which don't...

This is why guided help such as this forum exist. Independent research is a good thing. But guided instruction is the next tier up.

Older Windows has a preference for RAID, though it largely remains a Windows thing:
Key Differences Between AHCI, RAID, SATA, and IDE | Spiceworks - Spiceworks.

3 Likes

I had this issue on my Dell laptop. All the items I tried didn't work. I when into my Bios and set Ubuntu as the default boot partition and that fixed the issue.