Error: NVram is locked (Zorin not found in efibootmgr)

We wanted to get away from Windows and make our older Acer Aspire run better, so we bought a new hard drive and removed the old one with Windows to have as clean an install of Zorin as possible.
Unfortunately all we get after install is " Error: NVram is locked (Zorin not found in efibootmgr). Please report this message to".
After two hours of searching for a solution no one has one. We tried resetting the bios defaults and ensured there is no security password and we still get the same error.
I'm glad we didn't pay for Zorin yet or we would have lost that money as well.

1 Like

What make / model do you have? When I think of older I usually tend to lean toward the non-UEFI boot systems, heh..

In BIOS - do you see, or have any settings for Secure Boot, specifically? If so make sure it's 'disabled'. Security password is to prevent changes in the BIOS - separate item.

And, last one promise - try the Boot Repair utility in your USB installer through the provided live session (desktop). Select the Recommended Repair option and try to boot again once it completes.. if that doesn't work, provide any and all details including screenshots (if you can) to the reply :+1:

(edit) Almost forgot:

It's an Acer Aspire M3470G-UW10P. Only secure password, not secure boot. I already ran the boot repair. Twice. "Unable to repair. NVram is locked. Zorin not found in efibootmgr".

I suggest you read this very similar case I found in one google search Old PC won't boot working Mint install, "NVram locked" [Solved]

Installing yourself an unfamiliar OS often asked you to do some research and read documentation. Specially true in the case of Acer laptops that are often problematic with linux.

1 Like

So, in your log - thanks btw - I see:

Grub2 (v1.99-2.00) is installed in the boot sector of sdb and looks at sector 0 of the same hard drive for core.img, but core.img can not be found at this location.

That's telling me your boot style is MBR, older for sure. No worries, you just need to make an MBR type installer with either Unetbootin, or Rufus by changing the "Target System" format from 'UEFI' to 'MBR' and installing Zorin again. . Kind of a pain, yeah - but older stuff needs a slightly different installation method.

(edit) Also went right past this one:
=> No boot loader is installed in the MBR of /dev/sda.

I already read that and it's not helpful, nor applicable. I also did a considerable amount of research before trying Zorin. That was one of the reasons I chose to reduce complications by putting in a new drive and having a clean standalone version of Zorin.

1 Like

Found this other link with suggestions :

Might get a better milage with this one ?

PS : good idea to have linux install on a separate disk +1

I see no option to change to MBR. Rufus is not an option since they won't support Win7.

1 Like

There's no option to change anything for Unetbootin - it's just old lol it writes an MBR style image regardless.

You do have to format the USB first, did forget to mention that part - on me!

I did that but there is no option to change it to MBR.

Weird idk what happened there with my last post - anyway, yeah you don't need to change anything for Unetbootin.

This is the same process I used before that isn't working. Formatted FAT32 USB written using Unetbootin.

Hmm.. Do you have any CSM settings in BIOS? That was kind of a precursor to Secure Boot; another headache in itself lol .. Look for that and see what it is set to..

Nothing like that. I've wasted enough time trying to make buggy software work. Thanks anyway.

1 Like

The firmware is EFI-compatible, and is set in EFI-mode for this live-session.

Also from your log - if you're writing with Unetbootin it's not going to work after all. You'll need to use Rufus or Etcher to get an EFI bootable. Also you could just extract the .ISO file to the root of an NTFS formatted USB. But, do have that from the log so actually - I was wrong! But, won't work unless you write in an EFI bootable.. (edit) or, enable CSM / Legacy settings in BIOS and proceed with your MBR installed Zorin OS - it just sounds like a mismatch of BIOS and boot format to me. Pretty common though, nothing to take to heart.

1 Like

Did you try it with the portable Version of Rufus? Another Tool that I know beneath Balena Etcher is YUMI. It haven't the fanciest UI but should work.

I finally got BalenEtcher to work and made a new install drive with a new download of ZOS and I get the same error. No boot drive detected.
There are no CSM / Legacy settings and no option in Etcher to change the format.
They sell Zorin OS as a savior of older computers yet clearly haven't addressed the requirements for older computers to make it work, and won't help unless we pay first. I'm not paying for software only to find out I still can't use it.

So you have purchased Pro of Zorin? If so you can get help directly from Team Zorin by filling out a Support Request here:


@swarfendor437 I don't believe the Pro version was purchased from an earlier post:

I know, this can be very frustrating - but, sounds like a BIOS setting either enabled or disabled preventing boot. Or, possibly a different device selected for the first boot device other than the HDD/SSD which won't have a bootloader and throw the 'no boot device' error.

Are you able to enter BIOS and see your boot device order? Just make sure that your HDD/SSD is in the first spot..