"Error unmounting: target is busy" when resizing volume in Disks (to enable hibernate)

I'm trying to enable hibernation on my system by following this guide:

On step 5 when I resize the volume in Disks to create a swap partition, I get the following error:

Error unmounting /dev/nvme0n1p2: target is busy (udisks-error-quark, 14)

It's because I'm currently using that partition right? Would it work if I live boot Zorin from a USB and do this step there?

There are active or pending disk writes, it won't let you alter the partition, yes doing it from a liveusb will work, can also try a reboot, and try again, if it is your / or /home then a liveusb will be the best


Thanks, I tried it (with a Mint USB) and it worked. Then I just followed the rest of the steps on my main Zorin. (but hibernation still doesn't work :face_with_diagonal_mouth: I'll open a new thread for that)

1 Like

Gday @axylox .
Glad to hear you fixed the issue.
Could you please 'Mark' the post that helped as "Solution".

This lets Others know they can find a solution here that may help them.

Solution pic

Thank you.
Zorin Forum Community.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.