"Error while refreshing cache" error

When I tried to update using software updater, I received the "Failed to download repository information". I tried to switch the Download from to Main server and when I click reload it shows the "Error while refreshing cache". And sudo apt-get update doesn't work as well. What should I do?

Disable Google Chrome in your repositories should do the trick.


In addition to @Storm 's advice, it looks like virtualbox repository you added is broken and needs to be removed.
Virtualbox is part of the Main Universe repository, so you need not add anything.


I disabled google chrome in the repos as @Storm have said. And I also disabled virtualbox as you've said. But after reloading, it says "Error while refreshing cache" but when I clicked cancel it says "Update software is available for this computer." and below it says "The updates have already been downloaded." What happened here? Did it work?

The remaining error is the Debian Virtualbox repository. Please doublecheck in case you added more than one.


Thanks! It worked now

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.