.exe and .ex

It's so strange, I expected to read Flash Player.exe as everywhere else.

I asked Google Bard (In the process manager in Zorin OS Core I read Flash Player.ex, how is that possible? That software is a Windows executable, so I would expect to read the .exe suffix.) and it explained that Zorin OS Core includes a standalone version of Flash Player for Linux. This version of Flash Player is an ELF executable, which is the standard format for Linux executables. The ".ex" suffix is simply a way to distinguish ELF executables from other file types. In the past, Adobe provided a version of Flash Player for Linux that was a Windows executable with a wrapper that made it work on Linux. This wrapper added the suffix ".exe" to the name of the executable. However, Adobe stopped supporting this version of Flash Player in 2017. The standalone version of Flash Player that is included in Zorin OS Core was developed by an independent team of developers. This version is fully compatible with Linux and does not require any wrappers. By what I know, Zorin OS Core doesn't include a standalone version of Flash Player for Linux otherwise I'd have surely used that (assuming it was working of course :smile:) instead of bringing the flash player that I was using on Windows, the flat Adobe Flash player and FlashArch. And all times I used that flash player on Windows it worked as an .exe, not an .ex as Google Bard said to be, I never ran Linux software on Windows, I don't know how it would be. So, is this .ex thing explained correctly or not?

I don't know about the .ex extension, but on Linux the extension itself is not requirement, only a hint for some programs like the file manager to detect what default software to use when you double click on the file. What I'm guessing is happening here is that the author simply mistyped the process name, which otherwise would cause it to break. Try to search for it in the terminal with:

ps -ef | grep flash

Do you see it there with the same name?

1 Like

The screenshot shows "Flash Player.exe"
It is shortened in the task manager to .ex, though.

1 Like

Btw, excellent example of why not to trust GPT as they will come up with whatever none sense just to produce the output they are programmed to spit out.

1 Like

luca 13665 13655 0 20:42 pts/0 00:00:00 grep --color=auto flash.

You mean that Google Bard explanation isn't correct or you say so because I was confused by the thing :sweat_smile:? I only “tried” ChatGPT, I don't remember what it had wrong because I couldn't input anything so I searched around and when I read $5.00 in its settings I logged out immediately :smile:. I prefer Googe Bard for now, it works just fine, it's free and easy to use. But I noticed certain problems and a recurrent typo when using it, I expected it. @Aravisian, yes, that's what surprised me, totally unexpected :grin:.

What I'm trying to say is that these programs are designed to produce text no matter if it's inaccurate or entirely made up. And if you have to double check what they're saying you might as well research on your own.

It's just something to be aware of, that's all.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.