Failed Upgrade 16.3 core to 17 core: Unmet Dependencies

Upgraded from 16 core to 17 core. During the upgrade I stepped away, but when I came back, laptop was off. When I turned it back on, I was got an error that packages had unmet dependencies.

I have tried to uninstall, reinstall the packages or somehow satisfy the unmet dependencies, but no luck. Any idea how to recover?

Have you run

sudo apt --fix-missing

sudo apt --fix-broken install

sudo apt update && sudo apt upgrade

sudo dpkg --configure -a

Yes I've tried all those, no luck.

Welcome to the Forum!

You could try to reinstall libgnome-desktop-3-19 and libmutter-11-0. Or You try to manually install the Package libgtk-3-0.

Libgnome installs fine, libmutter errors out saying packages have unmet dependencies, and libgtk is already installed at latest version.

Libmutter error says Depends: libgtk-3-0 >=3.19.10 but it is not installable. It says this for both libgnome-desktop and libmutter.

Its hung up on installing libmutter-11-0 it seems. It does not like the install of libgtk-3-0. It says 3.19.10 is uninstallable, but why? Is there a way to manually override this install or a way to force download and install?

When the system reboots it gives message:

Error: -ETIMEDOUT: PPM init failed

Hmm ... So, when I understand right a sudo apt install libmutter-11-0 don't work. How it is when you try sudo apt install libgtk-3-0 ? You could try to find it in Synaptic, too.

Correct, sudo apt install libmutter-11-0 doesn't work, it errors out saying its been held back because of unmet dependencies.

Installing libgtk-3-0 goes thru fine.

So, libgtk is installed but libmutter don't want to be installed ... Are there any other unmet Dependencies listed?

Correct, libgtk-3-0 is installed, but libmutter-11-0 will not install.

No other dependencies, at least its not flagging any right now.

Hmm ... Okay, let's try it with Synaptic. If You don't have Synaptic installed You can find it in the Gnome Software Store or You install it with the Terminal with the Command sudo apt install synaptic and there You search for libmutter.

I just installed Synaptic, but it won't launch since I only have a terminal interface. When Synaptic tries to launch it says Failed to initialize GTK. Is there a way to install libmutter using synaptic in the CLI interface?

To be honest I don't know. Maybe can @Aravisian or another more experienced User give an Advice to You.

Or You make a Cut and do a fresh Install of Zorin 17 if You have Your Data's saved.

I was considering using a live boot usb of Zorin 17 to try to run a repair job? Not sure if this will work or not.

There is a boot repair utility, but not an os repair utility.

Would you try sudo apt full-upgrade. It may require deleting the previous dependencies prior to installing new... this command allows that.

1 Like

First, I would recommend checking your Sources.
If packages are conflicting, there may be a package source conflict.

Once all sources are corrected or verified, you should be able to successfully run the commands suggested by @Ponce-De-Leon and @337harvey:

sudo apt update && sudo apt full-upgrade

sudo dpkg --configure -a

sudo apt install --reinstall zorin-os-desktop


Pretty sure the sources look good, at least from what I can tell in the terminal. And when running apt update and apt upgrade it hits 10 URL that are all Jammy. But running the last three commands for update/upgrade, dpkg configure, and install reinstall desktop still gives unmet dependencies:

@deltaONE11, the link to thread I posted above is pretty detailed. Please follow the tips within it to check your sources to a higher level of confidence than "pretty sure."
For example, (you do not need to elevate to Root privileges to do this) open /etc/apt/sources.list.d and ensure all files within state "Jammy" and not "focal".

1 Like

The only items listed in /etc/apt/sources.list.d are:


Then running:

sudo apt update && sudo apt full-upgrade
sudo dpkg --configure -a
sudo apt install --reinstall zorin-os-desktop

still fails saying:

The following packages have unmet dependencies:
   libmutter-11-0 : Breaks: libgtk-3-0 (< 3.24.33-1ubuntu2~) but 3.24.33-1ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

Any other things to check?