Firefox download location always goes to /run/usr/1000/doc/random


I upgraded from 16 to zorin os-17 pro a couple weeks ago. Overall I am delighted, and it seems to be a smoother experience on this old laptop than running 16 was.

My question relates to Firefox. I'm using the version supplied with Zorin OS. I have it set to always ask where to save downloads to. I have a set of lessons and lectures to download each week, usually around 10 different files, and I need to choose to file them where they belong.

However, Firefox is always opening the save dialogue into /run/usr/1000/doc/and a random subdirectory rather than remembering my download location. After a few files it is tiresome.

I checked about:config and tried changing '' to my desired location. It resets back to /run/usr/... immediately on the next download.

I've found this report of the same issue which seems to indicate its a snap issue (in that particular case). However, I'm using the system-supplied version which is Flathub, version 122.0.1.

Does anybody else experience this issue or know of a solution?

Many thanks

1 Like

Flatpak (Flathub) and Snap are similar in this regard: They are containerized apps staying completely in Root.
As you are using a Flatpak, you might try installing Flatseal to manage Flatpak permissions so that it can gain and make use of access to your User Home Directory and save files to ~/Downloads
Or you could install the recently released APT Mozilla repository and install APT Firefox:

1 Like

Thank you Aravisian. The apt install looks a bit daunting - at first look.

I thought I would give Flatseal a go first (I didn't know such a thing existed, so thank you). I am obviously not understanding it though. Under 'Filesystem' for Firefox I switched on 'All user files' and restarted FF, which then doesn't allow me to save downloads at all.

Resetting in Flatseal restores the initial situation. I'll continue to experiment.

1 Like

Update: I followed the instructions you linked to above, and now have the APT Firefox working perfectly. Thank you.


You are not alone in that. Flatseal stumps me pretty often, as well.

Good to hear. Is everything synced?

1 Like

Just to add, I replaced the provided Firefox (flatpak is the default one I think that comes with 17) with Firefox ESR tarball from the official Firefox site - just a case of extracting the tarball with the archive manager, selecting the 'firefox' icon in the extracted folder to launch.
Then changed the cog icon for the official firefox icon. Next, went into Main Menu (Menu Editor) and created a new entry under Internet, and when it comes to providing the command to launch, just create the path to the extracted folder in Downloads. The same works with Tor and Icecat Browsers.

Yes, thanks.

If Flatpak is the way forwards, then I hope that this management of its permissions can become more obvious and be a central part of system app settings. Thats a whole other discussion though.


I too, had the same problem.

Aravisian, thanks for the assist. I did not know about Flatseal.
Under Flatseal's Filesystem settings, I enabled:

All user files

Firefox under Zorin 17 is now behaving correctly, as it was under Zorin 16.

I only wish that I checked out the forums before spending time trying to resolve the issue myself.
Thanks again!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.