Firefox Home keeps defaulting back to start.zorin.com

Firefox keeps on changing everytime I start firefox to start.zorin.com. Like I know Zorin's startpage is quite cool and all but I prefer just using the normal Firefox Home when I start Firefox up.

Check your FF Homepage settings.
In FF, type this in as URL to see Homepage settings:
about:preferences#home

Maybe you have gotten Zorin set as your Homepage somehow.

1 Like

I set my homepage back to Firefox Home, but everytime I shutdown my computer, it goes back to start.zorin.com

Is it FF that came with ZorinOS package or have you installed it yourself?

I wonder if you have "Open Previous Windows and Tabs" setting enabled in FF General Settings. That would cause last used page to appear at start.
Otherwise, you could try and Clear all the browser Site Data in Privacy settings.

2 Likes

It is FF that came with ZorinOS.

Btw this never happened until I updated to ZorinOS 16.2

Your using a snap package or flatpak, delete it and use a .deb/.tar package

More info -> How to prevent Zorin from changing Firefox startpage on every restart

2 Likes

I was expecting an apt version according to his answer. I was not aware the ZorinOS ships with Snap version of FF.

1 Like

I've already answered this elsewhere. Settings | Home Page change to url of your choice. Done. Worked for me even in VM.

1 Like

Nevermind it solved the issue by itself...

I'm no longer getting that startpage.