[FIX] Bleachbit checkboxes covered by scrollbar

One of the things I have always noticed about Bleachbit is that it very annoyingly covers up the Checkboxes in the vertical gtk box on the left side. The scrollbar covers about 70% of the checkboxes (where you checkmark or uncheckmark the options you want to be cleaned.) It makes it very hard to check the boxes on or off.
I haven't used Bleachbit due to this annoyance... But as FrenchPress has praised it, I figured I would give it another chance.
And there was that annoyance, again.

So I navigated to the programs code and began looking for a solution. Logically, it would be in the GUI python script- and it was.
If you would like to fix this as well, navigate to /usr/share/bleachbit/bleachbit/GUI.py
Open it in your text editor (This method is easier than using VIM or Nano, but you can adapt to work in Nano if you like).
Hit ctrl+f to bring up search and search for

hbox = Gtk.Box(homogeneous=False)

Change that to true:

hbox = Gtk.Box(homogeneous=True)

Save and close it out. The next time you open Bleachbit,t he left side gtk box will have plenty of room to spare showing all the option checkboxes in full glory without them being covered up by the scrollbar (Scrollbar Overlay, or not.)

1 Like

I never experienced this issue myself. This is how my Bleachbit looks like.

I wonder what makes this difference between your installation and mine.

You keep titlebuttons on the left...
The divider line between the panes still looks very close on yours. Maybe sizing matters, too? Not sure.
Here are Before and After on mine in several different themes:
Before:

After:

Now I understand.
When I select the each item, I did see the scroll bar which is indeed too close to the buttons.
I did not notice till now since it never bothered me.

I imagine that Scrollbar Overlay and some themes will make a difference. You can see in the screenshots above, especially the one on the right - that the scrollbar actively covers the checkboxes partially. On mine, on some, it covered most of the checkboxes, leaving only a sliver of space to try to check or uncheck the box. So, it may vary person to person where the checkboxes are jammed up against the edge or are actually covered slightly to a lot.

I managed to take a screen shot with a scroll bar showing.

It is very close to the buttons but not covering them.

Yes, your checkboxes are very near but your MenuItem extends past the scrollbar. The two widgets should not get so close, much less interact like that.
bb-cover(ish)

This offered solution is for those who do have more interaction between the widgets:
bb-interact

Including Accessibility, for those that need Wider Scrollbars for better visibility.
https://www.google.com/search?channel=fs&client=ubuntu&q=wider+scrollbars+for+better+visibility+ubuntu

2 Likes

Wow! You indeed have sharp eyes.
I did not notice it till you pointed out.

If fact, I rarely use a scroll bar.
As I explained somewhere else, my wrist problem prevents me from using mouse for some years. I almost always use two finger scroll on my trusted Apple Magic trackpad.

2 Likes

I make themes...

These are among things I actively look for while testing my own monstrous creations.

2 Likes