Flatpak applications *always* open new instances, when they're not supposed to

The Problem:

Flatpak applications, notable those which have a panel status indicator (Like Telegram, Discord, or OBS Studio) all open new instances when installed and ran through flatpak, instead of focussing the already running instance

Things I have tried:

  • Checking any settings for always opening new instances - nothing out-of-the-ordinary found
  • running any given application with flatpak runin a Terminal --- issue persists
  • Checking online if anyone had similar issues --- no useful search results, tried multiple search engines
  • Properly updating the System using sudo apt dist-upgrade -y --- issue persists
  • doing a fresh install of ZorinOS 16 Core from the Revision 4 ISO --- issue persists

Extra Context:

  • This issue existed in other distributions when it first happened a couple of months back, though those Distros had it fixed relatively quickly, whilst Zorin has this issue (for me) to this day
  • I have not tried the Lite version to see if this issue is GNOME related.

Anyone here to shed some light on the situation?
is it just an outdated Flatpak build that ZorinOS is using? :thinking:

Please note that I have tagged this for the ZorinGroup to review when available.

Thank you!
in the meantime, do you have any machine to confirm this isn't just me being unlucky on?

as in, with some Zorin 16 Core installation and some program which uses AppIndicators (for instance - Discord, OBS, Telegram)

As it so happens... I have been working with @dasjdoom to enhance my understanding of VirtualBox and had installed Zorin OS16 Core on it last night.
let me see what I can do.


Confirmed:

okay cool so at least I'm not just incredibly unlucky
though I don't wanna screw up my Flatpak installation by manually installing a newer one, so I'll wait for ZorinGroup to push something

As a good many of the members in this forum have an inclination to avoid flatpak and snap, have you tried installing the .deb versions of the software in question? I use slack and discord, both of which do not have this issue in the .deb versions. Both open "existing" processes by the taskbar indicator. This may have something to do with flatpak, not the way the OS handles it... but only the devs would be able to confirm such.

Telegram doesn't offer official .deb releases, and I'd like to stay away from Discord (outside of Flatpak with some permissions changed) as their privacy practices are generally questionable

However, I can confirm that website releases of Telegram don't suffer this issue.
At the same time however, the very same Flatpak version of Telegram works fine across any other distribution I have tried on MANY different Desktops, notably Arch Linux, Solus, Fedora, and clean Debian 11

I am aware that the website releases exist, and I have just been using that until the issue is resolved, though I much rather use Flatpak not only for sandboxing, but also Portals, Permissions, Installation in User-Space, as well as it being Distribution-agnostic.

1 Like

16 posts were split to a new topic: The Great Flatpak debate of 2022

Yesterday evening we released a new version of the Flatpak back-end software as an update which should resolve this issue. You can install this update from the Software Updater.

1 Like

You really ought to ditch Virtual Box for Virtual Machine Manager - so much better, but that said have been having some issues but resolved by deleting the qcow file and then creating a new one from the updated Windows 7.img that is now Windows 8. I still offer support to the Vision Impaired forum on professional advice on accessibility options that need to be run in Windows to check that they work.

Tried it... The Ubuntu repository version is Hopelessly broken with missing dependencies.
I gave a fair chance at researching the issues and following all the guides only to end up with
Nothing.
But truth told; Shoddy packaging was the deal breaker for me. If the developer is too inept to properly package the item so that it actually installs through APT, then I do not trust it.

I installed it via Synaptic Package Manager on Devuan.

Ubuntu... :frowning:

No comment - it still galls me that on boot up of an Ubuntu live disc or install it states "Ubuntu with Linux" - I don't think! :wink:

1 Like

Well, I will try again, later. A recommendation from you is not to be ignored.
At that moment, though, I was in a rare event of a poor frame of mind, as usual...

I suppose you could try adding a debian repo?:

https://virt-manager.org/download/