Fresh install, black screen with blinking cursor after GRUB menu

Hi, i recently purchase a new laptop and tried to install Zorin (16.3) alongside Windows 11 but can't boot to login screen after 2 installations.

The black screen appear right after i choose Zorin on Grub menu and after some time, this message appear :
usci_acpi USBC000:00: PPM init failed (-110)

My laptop specs :
Cpu Intel I9
Gpu geforce rtx 3050

Sorry if I made mistakes in english, some help would be really appreciated

1 Like

Did you disable Secure Boot on the BIOS?

Did you disable Fast Startup from within Windows?

Do you know what generation is the Intel i9 from? (13th, 12th, 11th...)


I did forget to mention some details, yes, i have disabled fast startup, secure boot and also bit locker (don't know if this is one is relevant)

I also had problem during installation first, my SSD were not detected but i managed to fix that by unistalling RST VMD devices in storage controller and disabling VMD in BIOS (my storage controller is now a NVM Express standard)

That's all i did before I installed Zorin

1 Like

I have an I9 13th generations

i am guessing that's where the problem is: Zorin 16 uses an older version of the linux kernel and the 13th gen intel cpus are too new to have support for it on that version

The solution I've seen others do that worked for them was to install a newer kernel version


Gday @bataba Welcome to the community.

Your English is perfect :+1:
i believe you need to disable RST & change the SSD to AHCI. RST runs on RAID.

If this doesn't help please tell us How you made the installation device & program used to create.
Rufus/ BalenaEtcher/etc ?
device= usb stick or SD card, etc ?
hope this helps.

1 Like

Hi @Ocka,

Thanks for your response

I believe I already fixed that problem by disabling VMD or am I wrong ? If not, I'm afraid I can't change the SSD to AHCI since I don't have this option in my BIOS, my Asus UEFI is pretty limited.

I installed, Zorin Core 16.3 following the tutorial as i already did with my previous computer, I used balenaEtcher with a USB stick.

I'm not confident enough with linux to follow the solution provided by @Sorro, updating kernel version prior booting, but I'll try tonight to install latest Ubuntu LTS version which has the desired kernel version and I'll see if atleast this os works

1 Like


I did install install Ubuntu 22.04.3 and everything seems to work !
So high probability it is indeed linked to the kernel version as suggested by Sorro.

But maybe RST is also handled better on this version, I really don't know myself.

I heard Zorin 17 will likely be released soon, I could probably wait to try again.
Or maybe if someone could explain with more details how I can install Zorin with the most recent kernel ?

Your doing great @bataba ,
ok as you know how to enter the bios, first id like u to update your bios. on Asus machines this is done via bios,,, just to help,,, your machine has the new BIOS called UEFI, so they mean the same thing (more or less)
Open UEFI goto Advanced & you'll see something like "EZ updater" or "EZ ????", this is a direct update & install,,,,,
I wouldn't worry about secure boot. the only thing you need to disable in Windows is "Fast startup" , if you haven't disabled this please follow these steps.
just disable fast startup @ this point leave 'Fast boot" enabled..

the next thing i would try is a different creation tool to make to bootable device... i would suggest "Rufus" on windows or "Startup disk creator" on Linux.
you should also check the download.. on linux you can use GTKhash or look for an app on windows that **Checks the hash key,, the hash keys tell you if you have a successful download,, not a broken download.
Here are the hash keys for all Zorin OS's..

lets see if any of this helps.
Note: Even brand new machines need the firmware updated,,,

With setting the machine to AHCI, to will be in the SATA (sorry i said SSD) section, but as you have got Ubuntu working i don't believe you need to change your BIOS setup at this point.

Added: while your in BIOS please set the Admin & Password this maybe needed... eg: if you Nvidia isn't listed, you will be prompt to allow the driver to be installed, this is whats called MOK (Machine Owner Key)

Good morning @Ocka

I did search for an option named "EZ something" but didn't found anything (see the capture i added), perhaps it's named differently ?

I recreated my bootable key with rufus and i checked beforehand the integrity of my iso file and every was fine.

I also added a password for admin in BIOS.

But again after the install, i get the first error i mentioned in my post :frowning:

I dont have an Acer laptop and my French is not great, but maybe have a click where I have circled "Firmware" on your first screenshot and see what you find.

1 Like

Oh sorry, I didn't even notice my BIOS wasn't in english and it could be challenging to understand for some.

I finally succeeded to update the firmware but unfortunately, it didn't solve my problem.

1 Like

Can you please test adding the nomodeset parameter to your Grub file?

You can follow this post here for the How To:

Reboot and test if you can boot into your Desktop Environment.

1 Like

Hi @Aravisian

I added nomodeset settings and it looks like the error I mentionned in my first message does not show any longer.

But my screen remain black with that cursor blinking :confused:

You can undo it by editing grub, removing that parameter and then running sudo update-grub

Have you tried the later kernel?

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

The command are not working when i type them in TTY but i suppose its because my laptop isn't yet connected to internet.

ERROR: '~tuxinvader' user or team does not exist.

And sudo apt update said he is not able to resolve domain like and many others.

Do you know any workaround to install the last kernel ?

Is there any reason i need to remove the nomodeset parameter as it seem to have fixed "something" ?

1 Like

Gday @bataba

When changing the the Grub parameters in the "GRUB_CMDLINE_LINUX_DEFAULT" line, can increase or decrease (hide) what you see when machine starts,
SO it is safe to leave "nomodeset",
If you removed all parameters on the DEFAULT line, it will show more information & may even help you see the errors.

I see you done a great job updating the Firmware :+1: , this means that you have internet connection.

i see above you mentioned you have no internet?

!st. did you first "TRY" Zorin OS before you installed & did it work?
2nd. When you installed alongside Windows, did you have the internet connected went installing Zorin OS?
3. If not internet when installing, when you chose "Install alongside" ,, did you leave the other options to "Run update while installing" & " Install 3rd party",,, "Checked" or "Unchecked"?

As for Zorin OS 17, we hope to see that in the next few month's...

Also is your Windows running in "S-Mode"?

  • To see if S mode is active, go to Start > Settings > System > About. Look next to Edition for S mode.
  • To turn off S mode, go to Start > Settings > Activation > Upgrade your edition of Windows.

You can manually update the kernel via the post above by @Sorro

Yes, you can boot into Recovery Menu.
Once in the Recovery Menu, arrow key down to Enable Networking before proceeding to Root - Drop to Prompt to run the above commands.

My reasoning is that it would be preferable to know if the more recent drivers in the newer kernel resolve that issue.

Hi everyone,

I finally followed the tutorial to update the kernel forwarded by @Sorro and now everythings work. Sorry this problem could have been solved some days before but I was scared I mess things up. Kinda dumb from me as it was a fresh install and i could easily restart from 0.

I will mark his response as solution, thanks you all, for your time and your kind responses (and again sorry if I wasted some of your time).