How to upgrade Zorin 16.2 to a newer kernel

In this tutorial we are going to explain how to upgrade the Kernel of Zorin to a newer or latest Kernel.
The reasons for upgrading are not only to be found in the necessity for latest and new drivers, but as well in better battery-management, as well in better processor-management, as well for developpers in global.

Frist we are going to install Ubuntu's Mainline Tool that helps us managing Kernels in a decent and easy to interprete GUI.

sudo add-apt-repository ppa:cappelikan/ppa

sudo apt update

sudo apt install -y mainline

After the installation you'll find Ubuntu Mainline Kernel ...... in your Global Menu of Zorin.
In the Kernels higher than 5.15.xxx there is a global upgrade of the libssl3 package. This package is not installable in Zorin, because Zorin is based on Ubuntu 20.04 and on that point all is running behind of the latest development.
So we are going to drag in the REPO of Ubuntu 22.04 Jammy Jellyfish

> sudo add-apt-repository "deb http://ca.archive.ubuntu.com/ubuntu jammy main"

This will add the REPO of 22.04 into Zorin ! Run after the adding a simpel

sudo apt update

sudo apt install libssl3

This will install the required pack for the latest kernels higher than 5.15.xxx
Remove now the REPO of Ubuntu 22.04 before you do anything else

> sudo add-apt-repository --remove "deb http://ca.archive.ubuntu.com/ubuntu jammy main"

sudo apt update

reloading the indexes of your Zorin installation.

Now we are simply install a newer Kernel. I did the install of version 6.0.9 -xxxx what is the latest stable kernel for Zorin to use.
Open Ubuntu Mainline Tool and search in the field for 6.0.9 kernel and simply click install
During this install you get a prompt for upgrading some requirements. click YES on that point Mainline will install the Kernel as well as some upgrade system packs (THIS WILL NOT BREAK THE SYSTEM AT ALL !!!)
Click close screen when the installer is done.
Reboot, and you are now on Kernel 6.0.9 or the kernel you have installed.

Ubuntu Mainline offers as well an uninstaller of older kernels , if you don't want the remains of 5.15 on the system just use the tool for easy removal (one by one ! )
You'll have Zorin 16.2 ,Gnome 3.38 shell running on the latest stable kernel.
Better Boot-times is a benefit on the way lol .

1 Like

A piece of advise extra and a warning :

There is an update for Kernel 6.0.9 , being Kernel 6.0.19 -- that is stable and good : no issues at all with Zorin 16.2

However, the mainline tool will show that Kernel 6.1.15 is also ready for testing and download.
Don't install this Kernel yet. It causes total freezes of Gnome after resume from suspend. I saw there is an issue on 'reloading' the Nouveau-driver when resuming from suspend. Reported of course as a 'bug' by many now.

So keep away from now from the latest Kernel 6.1.xxxxxxx as there seem to be a lot of bugs.
The total freeze requiers a Hard Reset ... no KB, no terminal, no ... nothing .....

One error in your first post, due to the forum code misinterpreting the text:

sudo add-apt-repository "deb Index of /ubuntu jammy main"

sudo add-apt-repository --remove "deb Index of /ubuntu jammy main"

... isn't showing up correctly. It shows up as:
sudo add-apt-repository "deb Index of /ubuntu 1 jammy main"
sudo add-apt-repository --remove "deb Index of /ubuntu 1 jammy main"
... and that borks /etc/apt/sources.list such that one cannot even do a sudo apt update.

The fix is to manually edit /etc/apt/sources.list to remove the errant entry, then do sudo apt update, then issue the proper commands:

sudo add-apt-repository "deb http://ca.archive.ubuntu.com/ubuntu jammy main"

sudo add-apt-repository --remove "deb http://ca/archive.ubuntu.com/ubuntu jammy main"

I wrapped the text above in preformatted text tags... otherwise the forum code did the same to that text as it did to yours.

I tried 6.0.19... SecureBoot borked it, it said the signature was invalid, so I disabled SecureBoot and tried to boot 6.0.19 again... it stalled mid-boot, just after mounting the last drive (/dev/sdg).

So I rebooted into the current kernel, uninstalled 6.0.19, and installed 6.0.9. It, too, stalled mid-boot, just after mounting the last drive.

[EDIT]
The same thing happens for any kernel later than the current one... apparently it's not loading ZFS.

But I will say, with SecureBoot disabled and libssl3 installed, boot is much snappier on the current kernel.

1 Like

Edited OP to include markdown backticks, removing the issue of Index of /ubuntu as a link.

1 Like

Well, I got from the Forumbot now a little training on some things. Thank you for correcting the code .

ZFS I had not yet tested ... I figured it would work ootb. Turns out to be indeed a no show. So I tuned up Ubuntu 22.10 to see what happens, but I ran (run ) a little out of time of private small issues.