Games do not start after Zorin update

I did a major update of Zorin yesterday. The update itself also worked, but since then most of my games no longer work - more precisely, there is a problem with the GPU driver (at least I suspect).
Minecraft does not start at all and brings directly the error message from the screenshot, other games from Steam run with 10 SPF (yes, I mean Seconds per Frame) or even slower. The graphics card then has a load of about 5%. Before the update, all games ran without problems.

I have already tried all the newer graphics drivers from "additional drivers", so far no driver has solved the problem. Does anyone have any idea how I can fix this?


We need more info;

sudo apt install inxi
inxi -G

Oh, sry, I completely forgot to include information about my PC.... :man_facepalming:

  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] driver: nvidia 
  v: 515.48.07 
  Display: x11 server: X.Org 1.20.13 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa 
  resolution: 1920x1080~75Hz, 2560x1440~144Hz 
  OpenGL: renderer: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2 
  v: 4.6.0 NVIDIA 515.48.07

Launching Software & Updates, then moving to the Additional Drivers tab, you should see a list of Nvidia Graphics drivers.
Can you try switching to the 470 or the 510 driver and testing if they work?

I used the 510 until the update - when it stopped working, I tried several alternatives, most recently the 515. I additionaly have now tested the 470, but it does not work either.

But I have another idea: During the update, the message came up that not all system updates can be performed.
I just opened the update management again and there was also the kernel still displayed as a pending update, although it was actually already installed yesterday. I'll try to install it again, maybe that will help.

Ah - partial upgrade.
In Software & Updates, on the first main tab, please ensure that the first four boxes are all checked and that the "download from" option is set to Main Server.

Neither the change of the server, nor the update brought the solution...
According to Zorin, however, there are no more updates pending either.

Can you please post the output from terminal from running:

sudo apt update && sudo apt upgrade

You can use if lengthy.

OK:1 stable InRelease
OK:2 focal InRelease                                                                
OK:3 focal InRelease                                                              
OK:4 stable InRelease                                                             
OK:5 focal InRelease                                                  
OK:6 focal InRelease                                   
OK:7 focal InRelease                                   
OK:8 focal-updates InRelease                                          
OK:9 focal InRelease                                        
OK:10 focal-backports InRelease                                       
OK:11 focal-security InRelease                
OK:12 focal InRelease                      
OK:13 focal InRelease
OK:14 focal InRelease
OK:15 focal InRelease
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

NordVPN may likely be blocking the full upgrade...

So should I remove the repo and try an update again?

Have you tried disabling Nord, then running

sudo apt dist-upgrade

disable? So just disconnect the connection?

I mean turn off NordVPN. Merely removing the repository will not affect the installed application other than that NordVPN would no longer get updates.

Nvmd, nothing with systemctl xD
I don't really understand what you mean right now. Should I just disconnect now or how do you mean that I should turn off Nord?

I think it is:

nordvpn set killswitch off

and to turn it on:

nordvpn set killswitch on

Ah, okay, now I see what you mean. But I never had and still have Killswitch on.

I need to be away from the computer for a while, but hopefully, the above helps point you in the right direction.
Using kill switch may help you complete the upgrade.

Okay, now you confuse me, np, what that should help xD. But anyway, I just ran everything again with active killswitch, that didn't help either.
I am also not quite sure if an update is really missing at this point. That was my theory, because the last update did not run correctly, but - at least according to Zorin - after the second update earlier, everything is now up to date and installed correctly.

Is there no way to find the problem directly in the driver? Are there perhaps any logs or debug options for the driver?

Does your software update point to Main Server or your local server in the country where you live? Try changing your update sources to 'Main Server' in Software Updater Settings Tab: