Games do not start after Zorin update

I have already changed the update server.
But I suspect the problem is less with the updates, with me everything is now up to date.

Is this issue now gone:

Does this issue remain?

I checked om my Zorin what games I have installed two games warframe not working and Path of Exile working. Warframe using directcx 11 but PoE can using Vulkan. So with that propably after updates something kicked from linux operating system. I saw some post here on Zorin why games not working.

yes, exactly.

Can you try:

sudo dpkg --configure -a

sudo apt clean && sudo apt autoremove

The next command will restart the computer:

sudo apt update && sudo reboot

Test which games fail to launch...

I have done this, but it did not bring any visible change.
About the games: Minecraft does not start. All other games that I currently have installed start, but only have seconds per frame, so they are hardly playable. The only game that seems to run without problems is Cities:Skylines, which was also developed natively for Linux. Games that run via Vulkan have this problem, that they have practically freeze frame.

Okay, I just tested Cities:Skylines again, something is wrong there too. In the main menu I just have a few FPS less, but when I load a game I have the same problem as with the other games.

How are you running these games? Lutris? Steam?

Minecraft via the vanilla launcher, all others via Steam.

What is your graphics card again?

sudo lshw -c video

Or with Inxi

inxi -G

2060 super

Do you have Vsync on?

And it was working previously on the 510 driver, right?

Interestingly, I just learned that the Ubuntu maintainers forgot to include 2060 in "Ubuntu-install"...
I do not know if that has been fixed by the maintainers, yet.
You can check if Nvidia is operating when you launch a game by running this command in terminal...

nvidia-smi --query-gpu=utilization.gpu --format=csv

I actually lifted that command out of my Nvidia Conky... but it'll work...
Another test you might try is

prime-run minecraft-launcher

Instead of launching in the usual manner.

If it is showing 0% when trying to run any game, that may give us a clue...

If you believe that vulkan or Mesa is the issue, you can try using the Oibaf drivers:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt upgrade

sudo apt install --reinstall libvulkan1 mesa-vulkan-drivers vulkan-utils

VSync I have on in some games, but I can't check that unfortunately, the games don't respond to mouse clicks.

And before the update everything worked with the 510, exactly.

nvidia-smi --query-gpu=utilization.gpu --format=csv

I once started Satisfactory and entered the command at regular intervals, the response varied between 0% and 8%.
But for info: I have a Ryzen 9, so accordingly a game can't even start without the graphics card - at least not with image.

prime-run minecraft-launcher

Zorin does not know this command with me...

And no, I doubt that Vulkan is the problem, after all the problem exists even in Cities:Skylines, which does not use Vulkan at all.

It should...
If you are using the 510 driver on Nvidia, that must work.
Perhaps I am incorrect about the minecraft-launcher portion.
What is the command to launch Minecraft using your method?

You mean you have a built in AMD Ryzen and also Nvidia card?

I'm currently using the 515 driver, I'll try a downgrade. But with this driver Zorin says that the command does not exist.
Edit: The same message appears with the 510.

Minecraft I just start via the search function, see picture

I built the PC myself and installed the Ryzen 9 5900X and took the 2060 super from my old PC - so yes.

I just tried to open Shotcut and found that it doesn't work anymore either. The problem is apparently not only limited to games, it seems to affects all somewhat more graphics-intensive programs.

Do you get the popup window for


Are the GPU fans working if you adjust the Thermal Settings?

The Starticon comes for a short time, but the Shotcut window itself does not open at all.


I just tried something else: I still have an old Zorin installation on my PC. I started it and did a full update. And lo and behold, I don't have the problems there.
So this doesn't seem to be a fundamental problem between driver and graphics card.
Could something have gone wrong with the update on my current installation? Is there any way to rollback or something?

You could examine the updates:

Then either rollback those packages or reinstall them. It may be a Tedious Task...

Okay, I'll take a look at that right now. But I just noticed something else exciting: When I called nvidia-settings, the terminal showed these messages... Can you do anything with them?

(nvidia-settings:10630): GLib-GObject-CRITICAL **: 11:49:34.805: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 11:49:34.932: PRIME: No offloading required. Abort
** Message: 11:49:34.932: PRIME: is it supported? no