Games do not start after Zorin update

No, sorry, those are all normal. You would not be offloading normally.

This often is harmless, but it it is not always harmless. In cases where it is obstructive, it usually means that

  • Secure Boot is enabled in the BIOS /EFI settings...
  • A module is blacklisted
  • A module is broken... which in your case, with that partial upgrade, it seems possible that the module is indeed broken or corrupted.

I'm afraid I'm going to have to give up. I have now updated my BIOS and checked that Safe Boot is off, also without success.
Then probably really a module is broken. A rollback seems too complicated with my knowledge and also too risky.
So now I probably have to reinstall Zorin or hope for an update that fixes the problem... Or do I see something wrong? And what would you recommend me now?

An option is to enhance knowledge if you lack trust in it.
Build yourself up in order to reduce risk.

Modules are included in the Linux Kernel.
Modules are also sometimes contained in drivers.
The Linux kernel is a large set of Drivers.

Try booting into the Earlier Kernel from the Grub Menu... (tap esc at the Motherboard screen until you see the grub menu if you do not see it on normal boot - then select `Advanced Options for Zorin > the Zorin listed with an earlier lower number kernel)
Or reinstalling the current kernel:

sudo apt install --reinstall linux-headers-5.13.0-44-generic linux-image-5.13.0-44-generic linux-modules-5.13.0-44-generic linux-modules-extra-5.13.0-44-generic

I also had the idea of booting with an older kernel, but that didn't work because files for it seem to be missing.
I currently use the kernel 5.13.0-52-generic - I probably have to replace that in the command?

Oh... interesting. Yes.

I have now both reinstalled and booted once with the old kernel (which now suddenly worked). Has also helped nothing :I

Well, now you know a bit more about installing kernels and choosing which to boot into.
It's not a total loss. With each trouble in life, we can glean knowledge and growth.
Up for a Reinstall? :grin:

Fancy? No, not really. But do I have much of a choice?

Sure, normally I don't find such problems bad either, as you say, you learn from it. But when I hang on something like this for 3 to 4 days without finding a solution, it's no longer fun.

1 Like

I hear you...
That is as much a part of life, though. Sometimes gotta grab the bull by horns, and twist that sucker into the ground.

1 Like

Well, never mind. Eyes closed and through, I'll try to hurry, maybe I'll have the most relevant ready for use again by tonight. Thanks in any case for your efforts!

1 Like

I may have found the reason. I just wanted to start a normal .mp4 file on the PC and got the error message... Surely this should be all pre-installed in Zorin? And before the update I could play the files too.... Could it be that this decoder was removed from the system and now triggers these errors?

Edit: Okay, that would have been too easy, too. I have used the command

sudo apt install ubuntu-restricted-extras

to install the appropriate decoders, it worked and videos can be played again. But it did not solve my original problem.

So, here for the sake of completeness: The reinstallation worked, now everything starts again as it should. Let's just hope that this will not happen again so quickly :smiley:
And thanks again to all who tried to help.

1 Like

Hello. My question is what you reinstalled? Whole operating system?

yes, I'll actually get back to you. Just under a month after I reinstalled the system, I had the same problem again. But this time I pulled another card and got professional help. Lo and behold, with our combined efforts, we were even able to track down my problem. I still can't say for 100% sure what the culprit is, but at least I can present the problem solution and the trigger.
Today I did both a system update and a graphics driver update. After a PC restart, my problems were back just like the last time. My guess for the cause of the problem is the graphics driver update.
But now the basis of the problem: After the updates FlatPak did not work anymore - at least concerning the graphics. This resulted in Minecraft (which I had installed via FlatPak) not even being able to create a window and Steam having extreme problems - it could not provide any performance.

Okay, as I said: The problem seems to be somehow the interaction between Flatpak and graphics driver, the problem solution is actually absolutely simple: A reinstall of Flatpak.
sudo apt install flatpak --reinstall
And lo and behold: The problem was solved.

1 Like

Well I don't used flat and snap packages.

I too have a 2060 Super and since the last update I cannot launch Steam games...
I tried the
sudo apt install flatpak --reinstall
but no change for me...

I downloaded the update yesterday and unfortunately I just had to find out that the problems are back, a reinstall - as you described - did not solve the problem for me either. My previous attempts to find the error were unfortunately unsuccessful. Do you have a solution in the meantime?

I changed from experimental to Proton 7.0.3

Thanks for the reply, but the problem is - or rather was, it fixed itself yesterday strangely without my intervention - not with Steam, but with Flatpak. Already the Steam interface did not start properly, the graphics card Steam had in any case not listed among the rendered programs. And without graphics card rendering, of course, no game can run.

I am curious if Zorin updated something back to fabric installation that why we sometimes need reinstalling some software. I was also changing from DE some software Zorin in Cinnamon KDE not working. That could explaining why some software and drivers working and some are not working.