Getting WWAN 413c:81b6 to work

I hope this is the correct section,

i am having trouble getting my 4G Modem to work with Zorin OS. It was recognized right after installation but i can't seam to connect.

I created a profile for my Vodafone SIM and activated the connection. I get "connecting..." for about 20 seconds, then it fails without giving me any information what failed.

Is there any way to get some kind of log?

Here are some additional information:
Dell Latitude 7370
Bus 002 Device 002: ID 413c:81b6 Dell Computer Corp. DW5811e Snapdragon™ X7 LTE
Vodafone Sim Card, APN, all settings left on default, PIN disabled on the SIM Card.

I do not know on this particular device... but can you please scroll down to Fixed in Ubuntu 20.04.1 LTS Release, 64bit! and see if this works for you?

1 Like

You mean removing the number and setting authentification to "PAP"? I've tried that, unfortunatly with no success :frowning:
Also, am i stupid or is it not possible to remove a "profile" after i have added it?

I've been doing some more research and found a way to get a log output for the whole connection thing:
when i enter nmcli c up Vodafone\ Vorgabe
Where "Vodafone Vorgabe" is the APN Profile i've created in the GUI it tries to connect (as if i did the same thing via the GUI), but then fails.
With journalctl -xe NM_CONNECTION=2a3e40a1-b373-4a65-a67c-468e73d28bf5 + NM_DEVICE=cdc-wdm6
I get the following output:

Nov 15 18:57:14 daniel-Latitude-7370 NetworkManager[838]: <info>  [1636999034.6059] device (cdc-wdm6): Activation: starting connection 'Vodafone Vorgabe' (2a3e40a1-b373-4a65-a67c-468e73d28bf5)
Nov 15 18:57:14 daniel-Latitude-7370 NetworkManager[838]: <info>  [1636999034.6062] device (cdc-wdm6): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Nov 15 18:57:14 daniel-Latitude-7370 NetworkManager[838]: <info>  [1636999034.6070] device (cdc-wdm6): state change: prepare -> need-auth (reason 'none', sys-iface-state: 'managed')
Nov 15 18:57:14 daniel-Latitude-7370 NetworkManager[838]: <info>  [1636999034.6089] device (cdc-wdm6): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Nov 15 18:58:15 daniel-Latitude-7370 NetworkManager[838]: <warn>  [1636999095.1813] modem-broadband[cdc-wdm6]: failed to connect modem: Network timeout
Nov 15 18:58:15 daniel-Latitude-7370 NetworkManager[838]: <info>  [1636999095.1814] device (cdc-wdm6): state change: prepare -> failed (reason 'gsm-registration-timeout', sys-iface-state: 'managed')
Nov 15 18:58:15 daniel-Latitude-7370 NetworkManager[838]: <warn>  [1636999095.1877] device (cdc-wdm6): Activation: failed for connection 'Vodafone Vorgabe'
Nov 15 18:58:15 daniel-Latitude-7370 NetworkManager[838]: <info>  [1636999095.1909] device (cdc-wdm6): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')

This may be a modem manager issue:

Reading through, there are some offered workarounds.

Thanks for your reply, unfortunately that seams to be a completely different card with a different issue though. The VendorID is different (12d1 as opposed to 413c) and the ProductID is therefore also different (1506 instead of 81b6). Also they seam to have a problem getting and IP, while i can't even get anything out into the Broadband Network it seams.

Different issue: This matters.

Different ID or card number... Not so much. There are tons of different numbers put on pretty much the same hardware with only minor differences and the same drivers will work across a huge range of network or graphics cards, much of the time.

But if it is not the same issue as you are having, then it may be barking up the wrong tree.
The most common cause in cases like these is that the Mobile Device is being seen as a Mass Storage Device, instead. You might check that.
Other than that, I would be searching the net as fervently as you.

I think the device is recognized properly, but there is just no communication.
i did some more research and it seams i need to change the modem to "QMI-mode". I can't seam to find out how though. Maybe this helps?

daniel@daniel-Latitude-7370:~$ sudo  mmcli -m 0 --simple-connect="" -v
[18 Nov 2021, 11:31:12] [Debug] Forcing request to be run asynchronously
[18 Nov 2021, 11:31:12] [Debug] Assuming '0' is the modem index
[18 Nov 2021, 11:31:12] [Debug] ModemManager process found at ':1.16'
[18 Nov 2021, 11:31:12] [Debug] Modem found at '/org/freedesktop/ModemManager1/Modem/0'

[18 Nov 2021, 11:31:12] [Debug] Asynchronously connecting the modem...
error: couldn't connect the modem: 'Timeout was reached'

I just don't really know hot to tackle this problem, since i am fairly new to the whole Linux thing...

I am not sure either on this particular device.

What I do know is the following:

  • It is usually easier than you think. If you are following a guide that is saying to run fifty terminal commands and configure a bunch of different things - it has a higher probability of being a wild goose chase. The simplest solution is usually the correct one.
  • In cases where an unusual modem is not communicating with the net, it is usually that the device is being detected - but as a Mass Storage Device. You can check this in your Disks app. It is better to check and confirm, than to think that is not it.
  • The more things you try while guessing in the dark, the higher the probability that a configuration can cause you much headache later. It's like fixing car... You do not want to spend a thousand dollars throwing Guess Parts at it until you hit the right one. Diagnose, first then make the attempt at repair.

Right now, I am literally multi-tasking like crazy and jumping back to threads when I catch a breath. I am sorry I am not being much help. When I have some time, I will try searching the net based on your model device and see if I can find anything useful.

But searching for fixing Vodafone issues sure isn't!

1 Like

I am sorry if I seam ungrateful, that's probably due to my less then perfect English, but let me tell you, I really appreciate every single reply and the research you do to try and help me! I've tried a whole lot of different things, but i was careful to revert changes that didn't fix the issue to make sure i don't make the situation worse.
Here is a screenshot of the disk utility, i am pretty sure there is no unexpected Mass storage device:

I have read many threads in the past days and gone down a few rabitholes, but i don't feel like i have gotten close to fixing the issue.

It is probably something really dumb, probably a single command i need to issue, a single line of text i need to add to some obscure configfile or script. But i don't really know how to go further, i kind of reached the end of what i can comprehend...

Do you know the make/model number for this modem?
Does that look like one of those?

or one of those?

1 Like

I agree. Well, we ruled that out with a confirmation. :wink:

This also lends the point; Trying to solve the problem, we may forget a simpler solution: A USB Wifi Dongle.

I know the Make & Model of the Modem, its a "DW5811e Snapdragon™ X7 LTE", also often referred to as a "EM7455B" made by "Sierra Wireless, Incorporated". I should maybe add that we are NOT talking about a USB Dongle type device, but rather an internal module mounted inside a Laptop.
This is about what it looks like (picture stolen from the web)

When you say "USB Wifi Dongle" I guess you mean an External USB 4G Modem dongle, also sometimes referred to as "Surfstick" or something similar, that's not a route I want to go though, since I specifically bought this laptop for the internal LTE Modem. I think a USB dongle sticking out from the side is an accident waiting to happen.

I could imagine swapping the modem to something that definitely works with Ubuntu/Zorin, if it is not too expensive. I'd have to be sure though, before i order anything.


Found this. It looks very involved.


Very good point.:wink:

Yes, it does. So much for "probably something simple..." I guess there always has to be an outlier...

1 Like

Actually it should be in the Hardware help category.
I moved the thread.

1 Like

One more site:

1 Like

I've tried that, i can't seam to set the "FASTENUMEN" setting to "0":

             GPSENABLE		0x04
             GPSSEL		0x01
             IPV6ENABLE		0x01
             SIMLPM		0x01
             GPSENABLE		0x04
             GPSSEL		0x01
             IPV6ENABLE		0x01
             SIMLPM		0x01
             USBSERIALENABLE	0x01
             SINGLEAPNSWITCH	0x01


Also to be completely honest i don't really feel comfortable setting things i don't really understand. From what i understand, since the command AT!PCINFO? outputs

State: Online
LPM voters - Temp:0, Volt:0, User:0, W_DISABLE:0, IMSWITCH:0, BIOS:0, LWM2M:0, OMADM:0, FOTA:0
LPM persistence - None

and not State: Low Power Mode, The Modem is probably NOT in "Airplane Mode", and therefore all of this should not be needed in my case, could be completely wrong though!

If anyone understand this better then i do, please let me know!

@Aravisian might have some idea.