Graphical distortion in certain Electron apps


I am running ZorinOS 16.2 Core with AMD 2400G (Vega 11) APU.

When I run certain applications like Slack or Newsflash with web content, I get graphical corruption in many menu items. The distortion seems to be related to other running applications - in the case of this screenshot, the Steam client is bleeding through.

In NewsFlash-GTK (RSS reader) I can see the Hamburger menu (ala Android) correctly, but clicking my RSS aggregation provider, I get a bunch of garbled visuals - and if I right click I get what you see in the attached screenshot - which is similar to what I see in Slack.

The size of the menu is correct, but the contents are distorted beyond readability.

I found a Reddit thread where someone mentioned having a similar issue on AMD hardware, but that person solved it by uninstalling nvidia drivers. I, however, seem to have no nvidia drivers to uninstall at all, so I am uncertain of what to try next. I get the same issues in Slack regardless of whether I use the Flatpak or the Snap version.


This definitely looks like a Graphical Driver issue. Your other thread also looks like a graphical driver issue.
You might have some luck with using the nomodeset grub parameter.

Although there is this, which is your same card, these tips this user provides to resolve their issue may be relevant to your card.

Thank you!

The grub nomodeset parameter fixed this issue temporarily. I'll test for the other one as well.

The "real" fix was to first install the AMD drivers for 20.04 - but instead of --usecase=workstation as written in the linked guide: amdgpu-install --opencl=legacy

1 Like

Moved marked solution to the Real Fix post. :wink:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.