Grub directory '/ect/default' does not exist

I installed Zorin lite and later installed windows 11 accidentally messing with grub bootloader in the process. I booted a try copy of ubuntu and repaired grub. Zorin Grub now works but doesn't detect windows 11.

I tried accessing grub via nano to enable OS_PROBER in '/ect/default/grub' and got a 'ect/default' no such directory.

At no point via nano was I able to access the '/ect/default' directory in zorin. I tried updating and reinstalling packages to no avail. Is zorins grub located somewhere else? Anyone know what's going on here?

it should be /etc ... not /ect! Typo? :wink:

Having recently installed Windows 11 for a family member it is dependent upon UEFI and Windows Boot Manager in the BIOS - if this is disabled then Windows 11 won't show period. It also uses GPT not mbr. Could be the issue, not sure.


Gday @memping , Welcome to the community!
Windows wants to be the boss, It likes to be installed first.
So as your just setting up, Start fresh again,
Install windows first, Then Zorin.
Try watching the first video here, if your trying to setup windows MBR as GRUB.

Hope this works.

1 Like

Make sure you're spelling 'etc' correctly.

Just FYI, the latest versions of Ubuntu (of which Zorin OS is a derivative) have removed os-prober (which detects other bootable OS's) due to a security hole.

Zorin OS has os-prober installed, if you've removed it, it won't detect other bootable OS's.

sudo apt install os-prober

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.