Grub failling instalation on Old Macbook 4,1 (2008)

Hi! I'm having some trouble trying to install Zorin OS Lite 15.3 32bit on an old Macbook 4,1. At first I was having struggling for it to launch, but it worked after trying the 32bit version and using YUMI to make the bootable device (for some reason it's only recognizing it as an EFI device through UEFI-YUMI). It goes through the installation normally and I've had trouble with grub before on some newer(2012-ish) machines but was easily fixed but changed the boot mode to legacy instead of UEFI. By my understanding, these old Macbook machines don't change the UEFI mode, right? As the installation was going smoothly before that, the SSD is already wiped and clean, so I don't have Mac OS X anymore, so I was just relying on the live usb to do some tests. After searching a bit I found rEFInd and maybe that help? But trying the instalation didn't do anything. Although, I'm not a professional so I'm justing jumping through hoops here trying to find a solution, all I'm really trying is to run Zorin as the main OS. As I'm completely stuck, I would really love suggestions as to what to try and do next, or what I may have done wrong. My partitions are only the default 2 that Zorin creates: sda1 as aprx 500MB FAT32 ESP and sda2 250GB ext4. Thanks in advance!

You also could try rEFInd:

See... this is why I need to read the Whole O.P. before I rush to answer...

Here is a Full-Length guide that you can peruse to see if it includes any steps you might have missed. This may be a more direct option than guessing in the dark:

You might consider a Fresh Start while following the guide as well.

1 Like

I'm sorry, that's where I'm finding my problems. I may have rushed the gun when I saw that it booted into the Zorin installer and tried to install it, wiping the SSD and getting rid of MacOS. So all the tutorials I've seen, such as this one that you sent, start from the MacOS environment. So I'm not really sure about how I would go and install rEFInd. I tried using the terminal through the "Try Zorin" area and followed the " Installing rEFInd Manually Using Linux" page from the website, but when I restart it doesn't boot into rEFInd, nor does it recognize the /boot/efi folder and content that I created previously. Other than that, I don't know how would that affect the Zorin installation, does it try installing grub automatically? If I install refind it recognizes it and skips that bit, or is it a whole different way of booting into something? Sorry, for all the questions, I'm trying to learn and see if I'm going about it from the right angle.

Yes. Installing grub is included in the Zorin OS Installation. Or...automatically.
Installing rEFInd is neither skipped nor managed. Instead, it places the necessary files that the Zorin OS installer utilizes.
You would not boot differently nor really notice a change. Zorin OS cannot selectively choose to ignore it... It could only fault out - which is unlikely to happen.

I think it is more likely that something else is going on here.

What happened when you tried MBR (Legacy) mode?
How many existing partitions does the drive have?

Well, I can't seem to find a way to access the BIOS or something to change how the Mac is booting. Actually, atm it doesn't show anything at all if I don't have a usb plugged in. I may be scrambling informations as I was trying that for a long time, so I'll try again with a usb formatted with the ISO with BalenaEtcher alone and see if it recognizes it. But still, I don't see any signs that my rEFInd installation succeed. The drive seems to be(I don't have the specifics on hand right now) a Samsung EVO 250GB SSD, with two partitions(done by the first choice of the Zorin installation, "Erase and install Zorin") as described on my first comment, one 500Mb FAT32 with flags esp and boot, and another with the remaining approximately 250Gb ext4.

This eliminates my next question.
With MBR (Legacy), you can only have up to Four Bootable partitions.
I wondered if the Zorin Install would have been one too many partitions causing the problem... but this clearly is not the case.

So, now I have it on hand again and I was able to test what happens when I just use BalenaEtcher to make the bootable usb. It recognizes it(as EFI boot), but before appearing the "Try Zorin" screen it says "error: file /boot/ not found", then shows the normal screen. Going through with the "Try or Install Zorin OS" comes back with "failure reading sector 0x0404b80 from 'hd0'" and " you need to load the kernel first...".

This looks like the grub boot on the USB stick is corrupt.
Have you tried ReDownloading the .iso (Perhaps try a different mirror) and then reburn a new image.
I recommend using Rufus, Unetbootin or Multi-boot... Balena Etcher has a notorious history of rendering USB sticks unreadable.

That seems to be the problem. Redownloading it and using rufus stopped the "boot not found" and goes through to the Try Zorin. Still, the instalation only goes to the "installing grub2..." and gives out "the 'grub-efi-amd64-signed' package failed to install into /target/". That's the root of my problem, hence why I was looking for a way of not installing grub and finding an alternative.

In your BIOS EFI settings, is Secure Boot Disabled?

Is your EFI partition large enough?

Is the partition table GPT (you can check in LiveUSB - Gparted)?

Unfortunately, I don't know about Secure Boot and how exactly I can change it without Mac OS (it seems that I needed to have changed it with the Disc Utility). My EFI partition is 512Mb in size, as I've searched the ideal size is between 100~250Mb, so that's ok, right? And yes, I can access Gparted and it says that the partition table is GPT.

Yes, that is fine.

GPT is good...

I Forgot that this is a Macbook.:neutral_face:
It would not have Secure Boot as that is for Windows.

Searching the web, I found this response (Scroll to the bottom) in regards to a peculiarity on Macbook.

I tried using fsck to check the partitions integrity and it seemed fine, also tried making the swap partition and turning on ethernet but it still fails at the grub2 installation :pensive:

Well, you could try installing as MBR Legacy boot...

Sorry, but how can I do that? Do you mean having the Usb as MBR (If that's the case, it already is)? Or something related to the partition table?

In your BIOS Motherboard Settings, enable Legacy Boot.
How this is done varies a bit by the manufacturer.

When selecting your Boot Options from the motherboard after plugging in your USB stick and reboot, select the USB to boot that is listed without the "EFI" option.

The problem I'm facing is that I either can't access it, or it doesn't have BIOS settings accessible that way. I found this thread and it seems that Intel Macs only use EFI.

Startup option for access to firmware/BIOS - Apple Community

1 Like

We just cannot win on this MacBook...

Sadly :frowning:
That's why my initial ideal was to somehow bypass or find an alternative to the grub installation that was having problems. Because it seems like the rest of the process goes by fine. Any clue of what I could try?

Your question reminds me of this option:

I have never tried this, so I cannot fully vouch for it.