Grub Menu disappears after Lenovo Bios Update

Dual Booting Win 10 and Zorin 15.3. Had modified Grub so win 10 was default. Yesterday laptop had a bios update, after update booted fine and had grub menu...after restart just goes straight to windows. What should I check for?Maybe a setting in bios I had turned off?

Could be #2-#3 here: Before you install
Probably not #4.

1 Like

Thanks, kinda what I was thinking as well. If it is 2 or 3 do you think changing settings back to off, grub menu will just start working or will I have to re-build it?

I have experience with 2 - turning it off is what works for me on my dual boot.
Aravisian and others have recommended turning off 3, which is why I put it on the list, but I can't opine for lack of my own experience.
Definitely try 2 and then if the problem persists turn off 3 as well.

1 Like

#3 (Fast Boot) must be disabled as fast boot locks the drive, preventing changes from being written to disk.
This makes sense since what makes Fast Boot work is that it loads an Image of the disk. If you change the contents on the disk, that image would no longer apply- it wouldn't work.

#2 - disable Secure Boot- this one confuses me. I understood it to be as necessary to disable as Fast Boot it. Yet, I have come across many users that say they have it enabled and working fine. It may be a case-by-case basis where operation is sensitive to initial conditions. But personally, I highly recommend disabling it. While it may appear to work sometimes, it may rear its head to not work when you least expect it or have forgotten that it exists by then and are pulling hair trying to troubleshoot.

1 Like

Actually I don't think it is the issues #2 or #3. From the way you described it, it seems that your computer is using the Windows Boot Manager and it is not using grub. I suggest you to open your BIOS and check for your current boot options. Swift through the settings and see if you can find the Grub bootloader (sometimes called Ubuntu). My BIOS has the option to select and reorder the bootloaders so I see both Windows Boot manager and grub. I think in your case, after the BIOS update, your computer has changed the default to Windows boot manager. If that is the case, you can chnage the order and you should be good to go. If not, then its possible that the Grub bootloader got corrupted or your computer's just not cool with using it. In that case I think your only option is to reinstall grub.

1 Like

Thanks guys, Secure boot, etc was still off, issue was what taha_mcp said, in bios setting windows boot loader had been reset to 1st option instead of ubuntu. Appreciate it..gradually getting the hang of this :wink:

2 Likes

Great:) Can you please mark taha_mcp's post as "solution" so that others can find it?

Done, thanks again