Grub not working correctly after last update

After the last update when I turn on my computer it goes into the Grub Minimal bash menu. If I type exit and hit enter it goes on to the regular boot menu showing LM and Zorin with Zorin first as it should be. I found this thread: After installation. There is no Grub Menu. GNU Grub minimal Bash.
However nothing I tried from that thread seemed to fix it. When I changed my boot order in Bios then it booted correctly but the next time it reverted back to the Grub Minimal bash menu again. Grub was working fine until the last kernal update a few days ago.
Does anyone have any suggestions? Thanks in advance for whatever help you can give.

Have you tried entering the Advanced options for Zorin and booting from the previous working kernel, yet?
Did you boot a LiveUSB and run Grub Repair?

I tried going back to the earlier kernel but when I rebooted I still got the Grub Minimal bash menu. And when I live booted and ran boot repair I got a message that it failed because NVram was locked. I did upload the failure log to this address:

I don't know if that will help you at all or not. What seems weird is that all I have to do to get out of the Grub bash menu is just type "exit" and hit enter and then it goes into the normal boot-up screen. And after that everything works normally.

That on e is never any fun... You might try clearing the CMOS by pulling the battery and holding the power button down for thirty seconds or so to drain the capacitors.
Or resetting all BIOS configurations to default, then disabling secure boot.

Well since it said Nvram was locked I thought that might be because it was running from the USB stick. So I rebooted back into Zorin (after exiting the Grub menu again) and installed Boot Repair on my system. I ran boot repair and it didn't say it failed. However it said I should go into bios and set Zorin as my first boot choice. I did that and that time it booted directly into the regular boot menu with Zorin and LM as my choices. However the next time I restarted my PC it went right back to the Grub Minimal menu again. Here is the link to the new Boot repair log:

It has one entry in it a couple of times about not finding Module efivars. Whatever that is. Other than that it looks okay to my limited knowledge of Linux and boot operations. And it does show that secure boot is disabled.

I tried several things and none of them seemed to solve the problem. However since the last update I installed this morning the problem is gone. I now get the normal boot menu when starting my PC. So I am guessing the problem was with the earlier update. I'm going to call this solved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.