Grub Resolution

Hello, my grub menu's resolution looks kinda off(it's stretched). How to fix it?
Specs
OS: Zorin OS 16 x86_64
Host: Aspire S3 1.15
Kernel: 5.11.0-27-generic
Uptime: 22 mins
Packages: 1919 (dpkg), 16 (flatpak)
Shell: bash 5.0.17
Resolution: 1366x768
DE: GNOME
WM: Mutter
WM Theme: ZorinBlue-Dark
Theme: ZorinBlue-Dark [GTK2/3]
Icons: ZorinBlue-Dark [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i5-2467M (4) @ 2.300GHz
GPU: Intel 2nd Generation Core Proce
Memory: 2441MiB / 3784MiB

Try by first pressing c while grub is running to enter the console.

run

videoinfo

depending on your grub this may not work, if not run

vbeinfo

You're looking for a value labeled "preferred mode"

Once you have this value you have to edit the grub file to reflect this change.
Complete your boot into Zorin then open a terminal.
Run this command to open the grub configuration file.

sudo nano /etc/default/grub

then change the line starting with

#GRUB_GFXMODE=defaultxresolution

to:

GRUB_GFXMODE=supportedxresolution

exit nano and save changed before lastly running

sudo update-grub

which will update grub to reflect this change.

2 Likes

both vbeinfo and videoinfo doesn't work. My screen resolution is 1366x768

It doesn't work, I also realized that the grub screen on my other pc with Zorin Os 16 is different and looks excellent.

Does the grub menu look like the Zorin OS Theme as seen on the other machine?

Are you attempting to run these commands once Zorin is booted? These must be run on grubs command line which can be gotten to by pressing C when grub is open prior to loading Zorin.

I changed the #GRUB_GFXMODE=640x400 to 1366x768
The i sudo update-grub
It still looks stretched and blurry.

Did you remove the # at the beginning of the line? this denotes a comment so if you didn't remove this then this change did nothing.

1 Like

oh so # just ignores the command, I didn't know that. But it still looks blurry

One more thing the Manufacturer logo is supposed to be shown above the zorin os logo when booting right?

No, the manufacturer logo will appear on the Motherboard splash screen at boot. The Zorin Logo splash screen begins at Zorin OS initialization.

Interestingly enough, my system actually does show my motherboard manufacturers logo above the Zorin logo during boot. This was not my experience in any prior version of Zorin or any other Ubuntu derivative in the past. This is likely some sort of grub configurable option though that could be easily changed.

One of my computer shows the logo on zorin os boot and one doesn't.

I don't think its a grub thing i think its a gnome thing, cuz when i ran fedora gnome it has logo on the fedora logo.

1 Like

More than just interesting... I'm not even sure how that is possible...

That's what happens with me on boot. The first screen I see is the Dell Logo screen (that's the screen where F2/F12 work), then blank/black for a few seconds, then the second screen I see is the Dell Logo with ZORIN underneath, and then Zorin loads/opens after a bit.

Got me, and it probably isn't worth wasting any brain cells to try to figure it out.

This is different from how I interpreted the posts above:
I read them to say that the Manufacturer logo is appearing above the Zorin Logo - On the Same Splash Screen. Which would surprise me in many ways... Perhaps I am completely misunderstanding what they meant.

The motherboard splash and the Plymouth wait service are separate and distinct entities.

No, that is exactly what happens. The second (Zorin load) splash screen displays the Dell Logo in the center of the screen, with "ZORIN" spelling itself out underneath. Both on the same screen.

The Zorin splash screen must somehow be pulling in the Dell Logo, but I have no idea how.

On Solus, I also get two splash screens (boot load and Solus load), both identical with the Dell Logo only (no Solus branding) and the blank/black few seconds in between.

Mind.... blown... Just shows how little I know.

Really bad picture quality here so pardon that, but you can clearly see the motherboard manufacturer MSI's logo and the Zorin logo below. Like I said in my previous response, this is the first time I've ever seen this, but now I'm leaning towards it not being a grub option and being more likely something to do with Plymouth wait service since this occurs after selecting Zorin OS on the grub menu

1 Like