Hardware switch airplane mode

Hey guys, my apologies if i’m not in the correct category.
So here is the deal, my dad upgraded his HP pavillion dv7 notebook to windows 10 about 2 years ago. Ever since he has been unable to use any wireless features of the device. Basically it’s stuck on airplane mode through the hardware switch and it won’t turn back on… He recently purchased a new laptop and gave his old one to me to fiddle around with. I tried installing drivers, shut off and on the network adapter but no avail. I did read that many people faced the same problem after upgrading, so I thought the problem might be windows it self so I switched to Zorin OS instead, hoping it would somehow fix the issue, it did not -_-’ . After some more googling I found a method for windows that could fix the problem through the registery editor. By adjusting the value of RadioEnable_DWORD from 1 to 0. I don’t know if this truly would be able to fix the problem but my question is, is there an equivelant on Zorin OS to this? If so, where can I find this?

Sorry for the long message and thanks in advance to anyone willing to take their time of day to help me out!

That registry fix sounds viable, from what I recall on using Windows.

However, there is no such thing in Linux. Linux does not use an “explosion in a kite string factory” patch like Reg and Regedit.
Linux does not require defragging, due to the way Linux handles installation blocks and file management. That becomes a separate topic really- but the short is- No registry.

Can you open a terminal (Keyboard shortcut ctrl+alt+t ) and paste in

nmcli r wifi on

That turns Airplane mode off and turns wifi on

Check in your settings that it worked (Assuming you are using Zorin Core)
Open the Activities Overview and type in “wifi” and click open the panel, check that the Airplane Switch is set to Off.

This should give you two methods to use.

Thanks for your quick reply!
I just tried the method through the terminal line you provided. But there is no confrimation, just a new line appears below it. I checked just to be sure as you adviced to see the wifi in activities overview, but there is no change whatsoever. Is it possible that the wireless connections were permanetly damaged through the windows 10 update? Or ar there still some other methods I would be able to try to fix this?

There would not be confirmation in the terminal- I was thinking that in opening the settings, it would show if On or Off.

It is very remotely possible that Windows broke the hardware. An improper configuration that allowed too much current through the device that damaged it— But I would not consider this very likely.

In the WiFi Settings you accessed from the Activities Overview, that should be a GUI SWITCH that is showing airplane mode as on or off. Which was the second method I mentioned in my reply (This gives two methods…) One method was the terminal command and the other was flipping that GUI switch in the settings.
Did you flip that GUI switch?

I do not (and will not) use Gnome Desktop, so I cannot access Activities overview and get a good view of what you are seeing. In Zorin Lite, I would enter into terminal

sudo rfkill unblock all

For illustration purposes, screenshots of Gnome Desktop side of Zorin.

  1. Panel showing Airplane Mode = On, wifi shows = Off (airplane does not show in panel when switched off)
  2. Settings showing Airplane Mode switch = Off
    airplane mode ON in panel

@Aravisian My apologies I didn’t initially understand it on your first post. Airplane mode is currently switched on and it doesn’t allow me to switch it off. It says use hardware switch to turn off, but that doesn’t work either. Even though I’m running Zorin Core, I still did try the second line of command you provided just in case. It asked for my personal password, after which a new line opened. This however hasn’t fixed the problem either.

@zabadabadoo As explained to Aravisian, the OS won’t allow me to switch airplane mode off, but the weird thing is that the switch doesn’t appear in the settings, only in the quick access.

I provided a screenshot as well so you guys can see a clearer picture of the issue.

Whenever I use the hardware switch, it keeps turning on the airplane mode, even though it’s already on. It just won’t switch off through the physical switch, despite it still being functional. Are there any deeper level settings I could delve in to to fix this? Or would you say this is no longer salvageable, at least not through software.

Hmmm…
Can you detail information about the Physical HW switch? Is it a Physical switch dedicated to wifi- airplane mode? Or is it a Keyboard shortcut?

The F12 key has a tiny LED which indicates the current status. I can operate this by combining using the Fn key along with the F12 key. As long as its off, it remains orange, it used to turn white when it worked. But now, it doesn’t matter how often I press it, It keeps instructing the computer to switch on airplane mode eventhough it remains on all the time.

And both the fn key and the f12 key operate normally independently?

A Quick Explanation on Computer Components:
Let’s say you buy a Graphics Card and plug it in and start using it. You see an increase in your graphics abilities- a fine thing. That Graphics card has a processor, memory… Just like the motherboard.
And just like the motherboard, it is Programmed with an Operating System. These operating systems, like BIOS for example, run independently of Windows or of Linux or of MacOS. The graphics card is not the only component that does this and many pieces of hardware are programmed with a system and code.
On any operating system that you use, e.g. Linux or MacOS, the OS of your choice does Not Instruct These pieces of hardware as much as They Communicate With Them. The GPU will tell your Linux kernel what it is Doing… And that is relayed to the xserver for the Xwindow system. This is different from the GPU being instructed what to do by the kernel or by x.
This is also true for pieces of hardware that Plug into the motherboard by ports, such as USB. And it can be true for pieces of hardware soldered onto the motherboard.

I suspect in this case, that the HP component for this function is being affected in this way. Since you started the thread, I have slithered all over several aspects of the web. What I have found is a LOT of people complaining about this to HP and a lot of it is archived. In Publicly viewable spaces, HP Claims it is uncommon. No, it ain’t.
What I suspect is that when Windows did an update, it sent a command directly to the M.B. Hardware code that created the glitch. Since the glitch is in the hardware code, that is the place it must be fixed or addressed.

You might try an HP BIOS or Firmware update, then we can look at the Ubuntu Firmware, afterward…

Thank you very much, great explanation! Yeah that’s what I also found as well about this specific model of HP. I will also try the BIOS update during the weekend. And to answer your initial question, yes they do work independantly.

Then, the hardware is not damaged.

Thanks you again for your detailed information! I just checked to update the BIOS but it seems that it’s already updated to the latest possible version, which was released years ago. So my questions is what should I do now next? I understand that I have to possibly perform an Ubuntu firmware update, how do I go about this?

Try https://itsfoss.com/update-firmware-ubuntu/

I just tried the method as described on the link, it all functions as intended, up until the very last line code. After inserting that, only a new line appears in terminal and nothing happens.

What new line appears?

A clear line for me to enter a new command. Same thing as when you press the enter key when you haven’t written anything in terminal. Does that make sense? If not, I can post a screenshot.

Ah, ok. Yes, it does the same thing on mine if I run it.
It means that it has completed the command; no upgrades available.

Alright, now that the ubuntu firmware update method has also been tried, amd the bios is already in it’s latest version, what else is there left?

Probably some stuff we do not yet know.

In other words, do not lose hope. I cannot count on both hands how often I have seen someone discover a solution right at the brink. Currently, I am at a loss…
And for all we know- A wipe and reinstall of the Operating System might fix it.
But let’s keep researching…

As it stands, we know that anything windows did as an operating system cannot Carry Over onto Zorin. That was wiped clean.
It is possible that a Windows update carried a Firmware update with it and the firmware update is to blame- in which case reverting to an OLDER firmware might resolve- but I do not see that as being as applicable on Linux.

Again, thanks for being so patiently helpful, really appreciate it. Okay that all makes sense, would it perhaps be a good idea to install Windows again and try methods available through that OS instead, before reverting back to Zorin? Or am I misunderstanding things and that wouldn’t enable me to get to the proper settings to possibly fix this?