Headset mic not working

Hi! I've been using Zorin OS for the past 1 month and it's been really smooth and fast. My problem for it is that my microphone can't work whenever I plug it in (3.5mm jack) and it works for windows. (It always detects it as a headset but the microphone still can't work)

I've been referring to this article (My internal microphone doesn't work (ZORIN OS LITE )!) and I tried everything inside of it but it didn't work.

Another problem is I've been getting into cubing lately, but whenever I plug my cube timer in my 3.5 microphone jack, it always detects it as a headset and not Mic In. Last time when I was using Windows, I can select it as Mic In, Headset, Headphone & etc in Realtek Audio Control. Is there anyway that I can do it in Zorin OS?

Do you have pavucontrol installed?
If not, you can install with sudo apt install pavucontrol

Then launch it with alt+F2 and enter in pavucontrol

Move to the Input and Output tabs and note what is listed there and in the Drop Down menus. Is your Microphone detected and showing?

Can you list the brand, make and model or the Microphone?

I have installed pavucontrol, and the microphone is showing(even when I unplug the headset). The problem is, even when i plug in another 3.5 jack device it still appears as the same output and input device(the microphone couldn't work). The headset I'm using though is a normal Samsung wired earphone, and pavucontrol appears it as Headphones Stereo Microphone.

By the way, when I press alt+F2 and enter pavucontrol, it says "command not found". I have go to the search bar and type in pavucontrol and then click in PulseAudio Volume Control.

I actually really hope that I could use Realtek Audio Control in Zorin OS though.


No matter when I plug in my Samsung earphone, my cuber timer or even when unplugged it all appeared as like this.

(The digital microphone is my laptop's microphone which worked)

Odd. I just tested this and had no trouble with just pavucontrol in alt-F2 launcher.
What is the terminal output of

pavucontrol --version

It sounds like you may be suggesting that switching between input/output devices may be where the trouble is. Before proceeding, can you confirm if I understand this correctly?

Q1: After I typed in pavucontrol --version, it shows up Pavucontrol 4.0, is this the right version?

Q2: Yes, I need to switch between Mic In, Headphone, Headset & etc. My cube timer uses just a microphone, if I plug it in as a headset, it doesn't work.

Yes, it is. I am not sure why alt+F2 is not allowing you to launch it. Maybe that is a GNome Thing...

pavucontrol in alt+F2 works after I restarted the computer lol, don't know what's the problem tho.

How about changing the Headset... thing. Do you have any solutions for that?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.