My internal microphone doesn't work (ZORIN OS LITE )!

Hello all, I am new user of ZORIN OS LITE, I discovered that my internal microphone doesn’t work !!! I did some researches , AND I tried tried to change input devices setting ( front right /front left) and then my internal microphone works perfectly! but just after some seconds all my changes that I made before in Input Devices setting (front right/left) automatically changed to the default settings and my voices of course my internal Microphone could not detect any voice !!
so please I really need your help . bcs I am new here in Linux OS .

Can you try this and after that make sure no devices are muted?

1 Like

I really appreciate your fast reply and your help @carmar .
unfortunately NO GOOD NEWS!! I checked all and and the “PulseAudio Volume Control” already installed and THERE where I was changing and testing my microphone!!
the problem is when I make right changes here ! Screenshot_2021-01-24_00-32-46

I make front right 50 and front left 0 or 2 and my internal microphone works perfectly BUT . after 2 or 3 minutes all changes that I made change to defauls one automaticlly !!! I really stacked here

Can you check that your Software Updater settings look like: Software Updater settings (ignore wine)?

1 Like

On mine that I just tested now, I attempted to replicate your issue. I tested the mic, after clicking that padlock Icon, then I re-clicked the Icon before closing pavucontrol out and the mic continued to work.

Does this work on your machine, too?

1 Like

I think are same. and also everything updated
there are screens:
1

I tried both of them ! and the same result goes to old settings!

Can you try alsamixer in terminal (ctrl+alt+t) and see if playing around with the microphone levels helps?
Beyond that I will defer to Aravisian.

2 Likes

In terminal can you enter

sudo nano /etc/modprobe.d/alsa-base.conf

In the configuration file that opens, scroll down and look for the following line:

options snd-hda-intel model=auto

Use your arrow keys to navigate to the bottom of all the “options” line and add the above line if it is not already there. Then hit ctrl+x to exit, hit the Y key to say 'yes" to save, hit the “enter” key to save it as the original file. The terminal will now revert to normal.
Open pavucontrol and put all on proper settings- hit the lock, then immediately Reboot.
Test mic.

1 Like

I played with mic levels but no good news …

@Aravisian Big thanks to YOU , it works perfectly. same thing for @carmar thank you so much for your fast replying and all your efforts GUYS .
problem solved successfully .
:heart: :heart: :heart:

Hi , I am also new both in Linux and Zorin. I had the same problem than Abdel, but the solution didnt work to me. I dont know if I wrote the line in the correct place ( I wrote it in the last line of “all the option” line) but It didnt work. I also tried with other options I read, such as playing with the options of audio mixer and even with Gnome Alsa Mixer but nothing worked.
I also tried with an external webcam with microphone , but it didnt work.
Any sugestion?, I’m quite lost
thanks

Can you give the specs on your machine?